Ford Focus ST Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
7 Posts
Did anyone have any resolve to this? I just replaced my clutch and master cylinder and now it's acting up. It's doing the same exact thing, 66% when pedal is up, 100% when it's down. I unplugged the firewall sensor and it shows zero now. I'm wondering if I somehow damaged it? Anyway, did anyone fix theirs?

Thanks
 

· Registered
Joined
·
7 Posts
Did you even read the thread?
Post #44 shows what part you need and what sensor to connect.
Yes. I read the whole entire thread, but you never updated on if it actually fixed it for you. I'm just confirming before I order the part in question. Did you replace the whole master again, or just pull the sensor off of the new one and place it in?
 

· Registered
Joined
·
7 Posts
Well, I ordered the new part, hopefully it fixes it and that I don't need to take out the whole master again. I'll be sure to update if it fixes it to help future owners that may encounter this same issue.
 

· Registered
Joined
·
7 Posts
Thanks for confirming that it fixed yours. already have the battery/box out of the car, so at least there's that. I was able to unclip it and remove it without removing the pedal assembly, so I'm hoping I can snap the new one into place. I really don't even see how I could've damaged my old one... I guess they must be sorta delicate?
 

· Registered
Joined
·
7 Posts
So just wanted to follow up with an update, I swapped the hall effect sensor and it still gave the same code, however, I tested with the sensor hooked up to the master cylinder it came with and the fault went away. Meaning that there is an internal difference on the master cylinders with the sensors and the ones without. It's weird though, because they have a spot to hook up the hall sensor on both styles. Anyway, I guess I just have to swap the plunger assembly and apply it to the pedal mechanism. Oh well, hope this helps someone in the future. In other words, when buying one for a 15+, make sure that it comes with the sensor!
 

· Registered
Joined
·
7 Posts
The part # screenshot I posted before shows a master cylinder for an RS, 13, and 14 I believe did not come with this sensor.
You can buy the RS part and it comes with the sensor for sure. If buying for an ST they might ship 13 or 14 year cylinder
View attachment 404687
Yeah, that's the one I bought to get the new sensor. I just pulled the sensor off thinking I could swap just that, but it looks like I'll be having to pull the pedal assembly and swap the whole thing. The white pivot just unclips from the pedal assembly?
 
1 - 7 of 7 Posts
Top