Ford Focus ST Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
I have a 2013 ST with 55k miles on it. I have notice, quite a bit of oil all the way around the valve cover.
Has anyone else experience this issue?
I haven't ever removed the cover.
What would be a good fix for it?

Thanks in advance.
 

·
Registered
Joined
·
299 Posts
First,

I'd clean all of it up and then monitor closely to see if you can pinpoint the specific location(s) of the leak. Whereever it's leaking, replace the gaskets. Valve cover gaskets are particularly easy.

Good luck.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
First,

I'd clean all of it up and then monitor closely to see if you can pinpoint the specific location(s) of the leak. Whereever it's leaking, replace the gaskets. Valve cover gaskets are particularly easy.

Good luck.
Is the cover a gasket or a silicone seal?
 

·
Registered
Joined
·
848 Posts
Check the torque on the bolts. Some guys here have noted that theirs were hand-tight. Cinching it down to spec may stop the weeping.
 

·
Registered
Joined
·
1,813 Posts
I am heavily modded though. I'm not sure if they would void my warrenty or not.
No mods have nothing to do with your problem and besides you only have ~5000 left in your standard power train warranty. Also looking at your mods if something goes boom I doubt you would de-mod, take it to Ford and try to claim warranty....don't know but just a guess
 

·
Registered
Joined
·
300 Posts
I have a 2013 ST with 55k miles on it. I have notice, quite a bit of oil all the way around the valve cover. Has anyone else experience this issue? I haven't ever removed the cover. What would be a good fix for it? Thanks in advance.
If you switched from Dino synthetic oil to synthetic that could cause a leak.
 
1 - 18 of 18 Posts
Top