Ford Focus ST Forum banner
1 - 7 of 7 Posts

Registered
Joined
22 Posts
Discussion Starter · #1 ·
Hey everyone!

I've been updating everything from SYNC 2 to 3 in my 2015 ST and I've ran into a problem with the USB Hub module. I'd like to update from SYNC 3.0 to the latest update 3.4. I purchased from Amazon "Genuine Ford Transceiver HU5Z-19A387-B" from a Ford parts dealer. What I received was part number HU5T-14F014-AC. They look identical with the single port. I also bought the adapter for the power supply as well. Everything fits perfectly and when I went to test it, nothing worked.

All cables fit fine and I know the USB port lights up when the headlights are on but this one doesn't. Is this part interchangeable or is Ford so picky about stuff that they have slightly different alterations of the same USB module?

383973



But yeah everything fits in fine but none of the USB ports work, even the one under the center control stack. Am I missing a part or anything? Greatly appreciated for your guy's help.
 

Registered
Joined
468 Posts
This is going to be a dumb question... you plugged the USB cables back into the hub when you removed your old hub right? 馃槄
 

Registered
Joined
22 Posts
Discussion Starter · #3 ·
This is going to be a dumb question... you plugged the USB cables back into the hub when you removed your old hub right? 馃槄
Yes I already did that haha I checked. I got my old USB Hub back in and it works. The new one does not. I have no idea what's wrong.
 

Registered
Joined
468 Posts
I'd be willing to bet you got a dud hub 馃槵 Weird the the old hub works though -- usually Sync 3 throws an error about an incompatible hub when the old one is in
 

Registered
2013 Ford Focus ST1
Joined
1,775 Posts
FWIW, I did a recent SYNC3 upgrade (as Brian knows well!). I purchased the USB hub that was recommended and linked to on Brian's site. While it does work (and also supports two USB inputs as well), I do have an intermittent connection issue with it (the cables need to be "wiggled" or trapped in a specific orientation to maintain connection). I have not dug into this yet as I have gotten it to work 99% of the time.
 

Registered
Joined
22 Posts
Discussion Starter · #6 ·
FWIW, I did a recent SYNC3 upgrade (as Brian knows well!). I purchased the USB hub that was recommended and linked to on Brian's site. While it does work (and also supports two USB inputs as well), I do have an intermittent connection issue with it (the cables need to be "wiggled" or trapped in a specific orientation to maintain connection). I have not dug into this yet as I have gotten it to work 99% of the time.
Interesting. I know the cables are wrapped up in electrical tape and foam to protect it which did make it a pain to handle and move around understandably. I'll give it another go tomorrow and see what I can find. I just hate cramming my hand into that tiny plastic hole.
 

Registered
Joined
22 Posts
Discussion Starter · #7 ·
I'd be willing to bet you got a dud hub 馃槵 Weird the the old hub works though -- usually Sync 3 throws an error about an incompatible hub when the old one is in
Yeah it just charges. I still get an error saying to USB hub error or whatever but it does charge which means the old one is working. I dunno I'll have to do some more digging. Went through all that hassle for this. So dumb.
 
1 - 7 of 7 Posts
Top