Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey everyone,

I've tried searching far and wide through multiple forums about someone having the same issues as I am - with no luck. Before my ST3, I have completed the Sync3 swap in my 2015 F150, with only the navigation fault issue (can be cleared through testing settings and GPS with Sync 3 v3 works flawlessly).

However, after completing the swap in my 2015 ST3, everything, including GPS, worked perfectly. At this point I noted that the Sync 3 was version 1.0. Being an update freak, I decided that I need to update the system to v3.0. I "registered" a similar vehicle on the Ford website (with navigation) to ensure that I could download the 3.0 update correctly, as applicable to my ST3. Once I upgraded the software, with no issues, I noticed that the GPS was indicating the no GPS (GPS with red circle and line through) 100% of the time. Having thought that this was simply because I was parked in the garage, this might be interfering with the signal. I parked in the middle of the wide open street, rebooted the car, with the same issue. Going into the testing settings, all satellite signals indicate that there are zero satellites. I had since tried to do a master reset, unhooking the battery, soft reset, and using the DR fault in testing settings to try and recalibrate (found on another forum). None of this seems to have worked. My thoughts are that something in the update file has glitched my system into not attempting to look for satellite signal whatsoever.

As a side (not sure if it is relevant or not) - Android auto works 100% when plugged in, and when I updated to v3.0, I installed my winter tires during the update. While it seems completely irrelevant, on the F150 forums people have mentioned that the way the GPS system works through Ford is that there is some reliance. Again, not sure if this is related, but I would love to get the factory GPS working again.

At this point I am thinking I need to downgrade to v2.0 or v2.2, but I have not been able to find a proper guide for vehicles with factory nav.

Any help would be greatly appreciated! I can post pictures if needed!
 

·
Premium Member
Joined
·
1,167 Posts
^^^ I was told similar by Ford, wasn’t totally clear on if you need the sync3 antenna or what...maybe we can get Brian in here to clarify ?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Update: I decided to purchase 2 new fakra connectors (Are you a human?), one for each the F150 and Focus ST. After replacing both of the ebay/amazon connectors, I'm happy to say that there are absolutely zero issues! (No navigation faults either). Would highly recommend anyone looking at swapping to sync 3 to purchase these!
 
1 - 6 of 6 Posts
Top