Ford Focus ST Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hey guys, I've got a 2015 ST3, and it seems like I get the "Performing System Maintenance" screen all the time. Yesterday I ran a few errands, and did 3 short trips. Every time I got in the car and drove to the next store, the screen was black for about 3 minutes, then did its "maintenance" then finally came back on. But this happened all 3 times. Today I went out again and it did it one more time. It will be fine for a week or so, then it happens again. My question to you guys is, is this normal? Could mine be having problems doing an update or something so it keeps trying to re-run?
 

·
Registered
Joined
·
882 Posts
That isn't normal that's for sure, I only see that when I re-flash the car and it resets everything.
 

·
Registered
Joined
·
2,843 Posts
same here... I was assuming it is because of the recall that is showing on the report? not sure why but mine wants to run a report once a day at least, I keep telling it no.

Can will be in the dealership very soon I foresee not having my car for a while :(
 

·
Registered
Joined
·
882 Posts
Just a thought, have you tried pulling the fuse for the Sync system, let it sit for a few min and then put the fuse back to reset everything? It's worth a shot before going to the dealer.
 

·
Registered
Joined
·
184 Posts
Mine has reset on its own a few times but never that many times in one day. There's a chance it tried to rest once but didn't complete. Then started over the next time you were in the car. It takes a reasonable amount of time to complete.
 

·
Registered
Joined
·
184 Posts
I always thought "Performing scheduled system maintenance" meant "Oops I just crashed and now I'm rebooting" (seriously). I know I'd read that on this site and it seems like that's what is happening behind the scenes.
 
1 - 8 of 8 Posts
Top