Ford Focus ST Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Alright, bit of a mind bender here. I recently got my ST back from an engine rebuild, due to a cracked block. Everything other than the headers is new. It (as mentioned in the title) is stalling at idle and in nuetral, much like the issue with the engine wire harness. Only problem is, every single recall, my car has been through. It's not the wire harness, that's all fixed up. All fluids are good, I've cleaned the MAP and intake sensor multiple times, just to have nothing happen. And it does it randomly. Ive had it back for 4 days now and it just happened this morning. New spark plugs, all gapped to spec, as was professionally rebuilt, and are stock OEM plugs. Only mods are a cold air intake, and a resonator delete. I used to have it flashed with aftermarket spark plugs, but then I had to get the block repaired, and it's flashed at stock right now. I'm wondering if I flash it back, will that have a chance of fixing the problem? It is possible that my PCM has the oldest version of their software/ engine maping on it, as it's a 2013. My flash model is a Ford performance procal M-14204-FST. Any help or suggestions would be appreciated. Thanks all!
 

·
Registered
2016 Focus ST2
Joined
·
789 Posts
I remeber you could modify your idle rpm with the editor through OBD. Might help raising it?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Not entirely sure on how to do that. Is there a possible function on the actual flash tool itself? Or is it something entirely different?
 
1 - 3 of 3 Posts
Top