Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter · #1 ·
Not sure if this is the right place for this thread, if not please move.

On to the meat and potatoes....I acquired a set of ST2 recaro seats for my 2016 ST1 focus st. I did some research before hand to know what I was getting myself into. What I had come up with was that I should get seats out of a 15/16 which share the same harness plugs so it would be a direct swap, no issues. So, I swapped the seats, ended up having my airbag light on directly afterwards. I bought a brand new drivers side belt buckle because the car was in a crash so i figured this may or may not fix my issue, but for my safetys sake i just went ahead with it. Did not fix the issue. I took my car to the dealership and a tech spent an hour on it trying to figure it out, but he was unable to make the light go away. So now, I desperately need your guys help. I suck with wiring/diagnosing electronics. This is what the tech told me/had in the notes on my receipt:

- found code U3000 control module
- perform network test pass
- on demand ocsm pass
- says incompatible part for rcm try to do pmi on rcm still same code

The tech said he thinks i may have fried the rcm because i did no unplug my battery when doing the swap. I talked to my friend who is a tech and he said he highly doubts i fried the rcm.

The sensor in the passenger seat that turns on/off the airbag seems to be working on the center console.

Unfortunately, I don't have my original seats as they had to go in the car that i got the recaros out of.

What do I do now? How can I go about diagnosing this? This is beyond my knowledge right now which is why i took it to the dealer, but they were no help and now I have a 1 year old car without functioning airbags. PLEASE HELP!!!
 
1 - 6 of 6 Posts
Top