Ford Focus ST Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter · #1 ·
So with about 133,000 miles on my ST full stage 2 since forever my ST finally had an issue! Code P04A7 which is something related to voltage B circuit range. Anyone else have this issue? The car was running fine, had a slight hesitation and then major hesitation and then shut off! It would crank over and start briefly and very rough and then shut off. It's currently at a dealership but they are (of course) backed up.

Thanks,
 

·
Premium Member
Joined
·
355 Posts
Seems like there is a short in the Exhaust Pressure control valve circuit?
Not entirely familiar with that.
 

·
Premium Member
Joined
·
3,725 Posts
  • Like
Reactions: Ljc0514

·
Premium Member
Joined
·
3,725 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter · #5 ·
Just a little update....picked up the car Friday they cleared the code and it started right up. Drove it a few times during the day with no issues. The tech said "this car runs fantastic". Sunday morning started it up, drove to end of road and it died! Sat for a minute hit the start button it cranked a little longer than normal and started up. UGH!!! They thought it had to do with the TSB on the wiring harness but that was completed years ago and they verified that it was done. I hate not knowing!
 

·
Super Moderator
Joined
·
9,539 Posts
I dread being a maintenance star-ship crewmen in the future. All these electronics on the car.
My next car may be a Bobby Boucher lawnmower. (If I can get Vicki Valencourt to tune it).
 

·
Premium Member
Joined
·
358 Posts
My next car may be a Bobby Boucher lawnmower. (If I can get Vicki Valencourt to tune it).
My early vote for post of the year!!!!!
 
1 - 8 of 8 Posts
Top