Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
2014 Ford Focus ST
Joined
·
6 Posts
Discussion Starter · #1 ·
So I have a tiny little oil leak presumably on the left side of my engine at the top. The leak seems to be right beside a belt and pulley. This is a 2014 ST with only 50k kms on it.

381352


It seems a little dark around that area and I'm wondering if this is an easy fix or if this is a tough one. Is it doable myself or should I call my mechanic? Any help would be appreciated!
 

·
Registered
Joined
·
418 Posts
A: look at your belt. Looks chewed up. Looks like a lot of belt dust in the area as well.

B: check your engine mount. I had a leak that looked awful. All over the side of the engine and it was the engine mount. Clean it off and inspect.
 

·
Registered
2014 Ford Focus ST
Joined
·
6 Posts
Discussion Starter · #3 ·
Yeah I do notice my belt is blackened on one side. What usually causes that? Are there any common sources of that?

I think my engine mount is fine. It doesn't appear to be leaking or have any residual oily stuff on it.
 

·
Registered
Joined
·
418 Posts
A guy I know who is a mechanic suggested it might be an axle boot. The oily stuff is the consistency of thick grease with suspended dust and dirt in it almost. @UnfocusedST @turboguy327
So you’ll have to look at your axle boots.

Just look around your belt, see if a pulley is off or anything looks weird. Unfortunately you can’t just pull the belt off and spin the pulleys. Belt isn’t supposed to be reused.
 
1 - 6 of 6 Posts
Top