Ford Focus ST Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
So i installed my big turbo, im somewhere in the 26lbs range right now, but my sct will only read 22.47lbs. Does anyone know how to fix it, i created my own datalog and i cant figure out which parameter would read it correctly. Thank you!
 

·
Registered
Joined
·
463 Posts
How do you know it's at 26 lbs? Where was the reading taken? The SCT is reading the digital ECU signal of the actual boost pressure recorded at wherever the sample is taken. If this is at the intake manifold, there is pressure drop through piping, intercooler, throttle body, basically, any restriction. 26 lbs may be what the turbo is pushing at the outlet of the turbo or on the hot side piping, but the actual engine may only be seeing 22 and change. The only way to "fix" this would be to move the boost pressure sensor.
 

·
Registered
Joined
·
5,568 Posts
So i installed my big turbo, im somewhere in the 26lbs range right now, but my sct will only read 22.47lbs. Does anyone know how to fix it, i created my own datalog and i cant figure out which parameter would read it correctly. Thank you!
Add "tip prs boost kpa" pid. Take the # and subtract 100 for atmosphere.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
So i installed my big turbo, im somewhere in the 26lbs range right now, but my sct will only read 22.47lbs. Does anyone know how to fix it, i created my own datalog and i cant figure out which parameter would read it correctly. Thank you!
Add "tip prs boost kpa" pid. Take the # and subtract 100 for atmosphere.
Kpa is showing around 26lbs. I just wanted it in psi lol the psi is ran off of pid, so it may not allow it
 

·
Registered
Joined
·
625 Posts
There is a pid for what you want, I'll boot up the computer and see what it's called in a little bit. It was within a few tenths of what my aux controller was reading.
 

·
Registered
Joined
·
625 Posts
Boost is PSI under Misc

Capture.JPG

Database version 106 but I have no idea when it showed up. If your database is not updating you need to run Livelink as Admin every time. Like SI said above, it may not be listed for your strategy.

I don't use this pid for anything. Maybe just to have on the x4 display? I use KPA normally.
 

·
Registered
Joined
·
625 Posts
Now I remember why I found that PID, it was to help with tuning my aux fuel controller. Wanted something that matched it's internal MAP sensor. Since I no longer use aux fuel I don't log it anymore.
 
1 - 9 of 9 Posts
Top