Ford Focus ST Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter · #1 ·
So I've read posts until I went numb. I know that I need resistors installed when I come out of my stock amp and go into my LOC7i and resistors on any unused outputs. I purchased 10w/10ohm resistors today.
I have my new amp, sub and Loc7i coming this week, however I already replaced all of my door speakers.

What I need to know is:
1. I used the front L and R woofer wires as inputs to my component crossover and crossover output to new door and tweeter. I unplugged the stock tweeter. Do I need a resistor on the unplugged stock tweeter output?

2. I unplugged my center channel. Do I need a resistor on the center channel output?

3. Do I need to do all of my resistors now, since the rest already go to speakers, or do it when they go to the LOC?

When the DSR1 releases, I'll be going that route, but until then its LOC7i.

Thank you in advance for any help.
 

·
Registered
Joined
·
473 Posts
You will only need to do resistors once the stock amp is no longer powering them. With just the sub and the center delete, no one has complained that the amp over heats. There is probably enough of a load for it to be ok. Personally i would leave the center hooked up since you will have the tuning ability for it later.
 

·
Registered
Joined
·
183 Posts
Discussion Starter · #3 ·
You will only need to do resistors once the stock amp is no longer powering them. With just the sub and the center delete, no one has complained that the amp over heats. There is probably enough of a load for it to be ok. Personally i would leave the center hooked up since you will have the tuning ability for it later.
OK. Right now I still use the stock sub, so it is hooked up. The only things not hooked up are the stock front tweeter plugs and the center, which I can plug back in.

Just wanted to make sure I don't fry anything before I get the rest of my new stuff. Thanks for the info !!
 

·
Registered
Joined
·
473 Posts
Pulling 3 tweeters off you might want to wire in a load on those. 1 = ok, 3 maybe not. Why did you unplug your tweeters? If youre still using your mids as a source for your lc7 you need to load those as well as use the signal. The LC7 does not keep a load on the amp.
 

·
Registered
Joined
·
183 Posts
Discussion Starter · #5 ·
I installed new component speakers and am using the crossover to send a signal to the new tweeters. I plugged my center channel back in, so the only thing unplugged now is the the original tweeter plugs on the front left and right. Nothing is going to a loc yet.


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top