Ford Focus ST Forum banner

1 - 5 of 5 Posts

·
Registered
2017 kona blue stratisfied stage 1 tuned
Joined
·
10 Posts
Discussion Starter #1
So i got my st back at the end of December and the cars amazing but it just feels like im missing some power down low. From 1st to like 4th it just feels like the powers not all there Also ive noticed from 1-2, 2-3 my boost gauge will barely move then in 3rd it'll sometimes go up a little past a quarter then in 4th it'll go up to right under half. I've seen videos of people being at like 75% all the way from 1st-4th pretty much and i just wanted to know if anyone else had a similar issue or if this normal cause ive never even gotten mine past half. My cars pretty much bone stock besides a boomba BOV and a resonator delete and i run 93 octane gas. I havent had a chance to check the hoses and such to see if anything is lose or broken but as soon as i do ill post an update.

Also i live in michigan and its the middle of winter with temps being right around 15-35 most days. Idk if this has anything to do with it but just thought id add it in.

Any info would be much appreciated (y)
 

·
Registered
Joined
·
1,013 Posts
Here's mine, stock tune 3rd gear, 12 degree ambient as you can see. Just above half.
377007
 
  • Like
Reactions: ArczyST

·
Registered
2017 kona blue stratisfied stage 1 tuned
Joined
·
10 Posts
Discussion Starter #4

·
Registered
Joined
·
1,013 Posts
1st is just wheelspin. 2nd is about the same as the photo.
 
1 - 5 of 5 Posts
Top