Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
354 Posts
Discussion Starter · #1 ·
Hello Everyone,

I haven't had the best of luck lately.

For the past few weeks I've noticed a loud pop the moment I press the push-button to turn the car off. This happens randomly, but lately it seems to be each time I turn the car off. Today I turned the A/C off and heard the same noise. I'm wondering if this "pop" noise I'm hearing is related to A/C?

I've also been dealing with an issue where the car bogs down very badly and almost turns off when the A/C compressor kicks on. Anyone every felt this? The whole car violently shakes and RPMs drop to almost nothing. Then everything returns to normal.

I'm wondering if I have a bad A/C compressor? Anyone experience anything like this ever?

--Bradley--
 

·
Premium Member
Joined
·
3,732 Posts
Hello Everyone,

I haven't had the best of luck lately.

For the past few weeks I've noticed a loud pop the moment I press the push-button to turn the car off. This happens randomly, but lately it seems to be each time I turn the car off. Today I turned the A/C off and heard the same noise. I'm wondering if this "pop" noise I'm hearing is related to A/C?

I've also been dealing with an issue where the car bogs down very badly and almost turns off when the A/C compressor kicks on. Anyone every felt this? The whole car violently shakes and RPMs drop to almost nothing. Then everything returns to normal.

I'm wondering if I have a bad A/C compressor? Anyone experience anything like this ever?

--Bradley--
Tons of posts on the bad idle, look up the "Wiring harness TSB". Turn off the blower motor when you turn the car off to see if the pop is related to that.
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #3 ·
Tons of posts on the bad idle, look up the "Wiring harness TSB". Turn off the blower motor when you turn the car off to see if the pop is related to that.
I thought the wiring harness was only for the earlier models. Apologies, I failed to mention mine is a 2016. I'm not sure there was a TSB for the wiring harness for this year.
 

·
Premium Member
Joined
·
3,732 Posts
I thought the wiring harness was only for the earlier models. Apologies, I failed to mention mine is a 2016. I'm not sure there was a TSB for the wiring harness for this year.
I'm not 100% sure on the year.

I'd check the gap on your plugs also, our cars aren't to nice to spark plugs.
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #6 · (Edited)
It seems to be from under the hood. It's just one loud "POP" when I turn the car off. I was able to replicate the same pop without turning the car off when I turned off the A/C the other day.

*Edit* I've dropped the car off at the dealership. Should be covered under warranty. I'll report back when I hear back from these guys. I'm guessing they are going to say they can't find anything wrong.
 
1 - 6 of 6 Posts
Top