Ford Focus ST Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Hey folks,

Something weird happened last week. After hard driving on the highway for 15-20 minutes I noticed a lot of power loss in 3rd and 4th gear. It felt like clutch slip or a clogged cat. The car would rev but the car didnt move accordingly. I immediately took it easy after that. Ever since then it has been driving okay. No slip in high gears, performance still seems to be a little off but I could be imagining it now.

Any thoughts on what it could be? Easiest way to test for a clogged cat? No codes.
 

·
Super Moderator
2014 ST3. Garrett Powermax turbo, Thermal Turboback, CPE intercooler, JBR intake, Innovative RMM
Joined
·
4,943 Posts
If rpms increased but car did not move, that would indicate a clutch issue.

If rpms did not move and speed did not increase, there would be a performance issue (not necessarily a clogged cat).
 
  • Like
Reactions: ST1Dale

·
Registered
Joined
·
41 Posts
Discussion Starter · #3 ·
If rpms increased but car did not move, that would indicate a clutch issue.

If rpms did not move and speed did not increase, there would be a performance issue (not necessarily a clogged cat).
rpm definitely moved but I can’t recall how much it moved. The issue is the car hasn’t done it since?
 

·
Super Moderator
2014 ST3. Garrett Powermax turbo, Thermal Turboback, CPE intercooler, JBR intake, Innovative RMM
Joined
·
4,943 Posts
rpm definitely moved but I can’t recall how much it moved. The issue is the car hasn’t done it since?
If you have another hard run, see if it does it again with similar driving conditions.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #5 ·
If you have another hard run, see if it does it again with similar driving conditions.
I have done hard pulls and it seems okay now. Although I haven’t done anything after 20 mins of hard driving. Could the clutch be more inclined to slip when hot?
 

·
Premium Member
2018 Ford Focus ST1
Joined
·
1,497 Posts
What are your mods? Are you running the stock intercooler or an aftermarket? Any idea what your charge air temps were when it cut power?
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #7 ·
What are your mods? Are you running the stock intercooler or an aftermarket? Any idea what your charge air temps were when it cut power?
I am 91 tuned with 5” INTERCOOLER and cold plugs. Unfortunately I didn’t have the charge temps on the gauge. That was another thought I had! But my charge temps have never gone higher than 10 above.
 

·
Premium Member
2018 Ford Focus ST1
Joined
·
1,497 Posts
Probably not heat soaked, then... Could be the clutch, though. See if it does it again in the future. Good luck.
 
  • Like
Reactions: TurboGT
1 - 8 of 8 Posts
Top