Ford Focus ST Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
243 Posts
Discussion Starter · #1 ·
I noticed a few weeks ago while sitting in traffic in 90 degree weather I turned the AC on and the temp started to spike on the gauge. I turned the AC off and the temp went back to normal. It just happened again today. Car is a 13, 72k mi on chassis about 10k on motor. No CELs car has a FRPP tune a plugs that have been installed for about 3k miles. Any thoughts on where to begin or what to check.

Sent from my Nexus 5X using Tapatalk
 

·
Registered
Joined
·
1,284 Posts
You may have air in the system.

Burp it
 
  • Like
Reactions: Duece McCracken

·
Administrator
Joined
·
13,291 Posts
I noticed a few weeks ago while sitting in traffic in 90 degree weather I turned the AC on and the temp started to spike on the gauge. I turned the AC off and the temp went back to normal. It just happened again today. Car is a 13, 72k mi on chassis about 10k on motor. No CELs car has a FRPP tune a plugs that have been installed for about 3k miles. Any thoughts on where to begin or what to check.

Sent from my Nexus 5X using Tapatalk
Do you still have active grill shutters? They have been known to malfunction and stay in the closed position sometimes. That would block your airflow quite a bit.

How are your intake air temps? If they are abnormally high then that would point to the AGS system as well.
 

·
Registered
Joined
·
243 Posts
Discussion Starter · #5 ·
So I have disabled the ags and burped the system and it overheats really quick with the A/C on as soon as you come to a stop, and with the A/C off it will overheat in about 30min of bumper to bumper traffic. Where do I look next, water pump? A/C compressor?


Sent from my iPad using Tapatalk
 

·
Premium Member
Joined
·
3,733 Posts
So I have disabled the ags and burped the system and it overheats really quick with the A/C on as soon as you come to a stop, and with the A/C off it will overheat in about 30min of bumper to bumper traffic. Where do I look next, water pump? A/C compressor?


Sent from my iPad using Tapatalk
When you disabled the AGS, did you confirm it is actually open and not still closed.
 

·
Registered
Joined
·
964 Posts
have you done anything to the wiring? I wonder if it's spinning backwards pushing the hot engine bay air forward though the rad and condenser..

Sent from my SAMSUNG-SM-G930A using Tapatalk
 

·
Registered
Joined
·
964 Posts
how long ago was the engine swap.. months, not mileage. and did you use your AC a lot before you noticed it.

I ask that, because it wasn't 90° during the winter months so you might not have noticed and issues after the engine swap.



The only thing that the HVAC has in common with the cooling system is the fan.

I'd at least look to make sure it's spinning the right way.

Sent from my SAMSUNG-SM-G930A using Tapatalk
 
1 - 20 of 25 Posts
Top