Ford Focus ST Forum banner

1 - 20 of 44 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter · #1 ·
Hey guys, Ive been plagued with a check engine light that i can reset, but comes back. Come to find out its over boost condition detected, and ive been told this could be a bent wastegate actuator rod, or my bov crapping out. As soon as i have time and its not 30 degrees out im going to investigate...

Just putting this out there if i need it, anyone have a spare stock BOV, and wastegate they dont need they can sell or give me just in case that is the problem, and I cannot fix it?
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #3 ·
ehe I'm looking for stock parts since I'm most likely going to be trading the ST in for a 2012+ mustang GT this spring...the ST has been fun and esp with my springs and shocks, but i miss having a V8 and rwd. If no one has a stock one for me, and the issue is the BOV and not the waste gate im sure I can buy yours for a lot less than what a new oem one would cost so ill keep you in mind once I know for sure whats throwing the CEL code.
 

·
Registered
Joined
·
73 Posts
ehe I'm looking for stock parts since I'm most likely going to be trading the ST in for a 2012+ mustang GT this spring...the ST has been fun and esp with my springs and shocks, but i miss having a V8 and rwd. If no one has a stock one for me, and the issue is the BOV and not the waste gate im sure I can buy yours for a lot less than what a new oem one would cost so ill keep you in mind once I know for sure whats throwing the CEL code.
I still have the stock BPV. I replaced it at 7k miles for a turbosmart. Pm me and I'll send it to you as long as you pay shipping. BPV is free.

Sent from my XT1585 using Tapatalk
 

·
Premium Member
Joined
·
2,022 Posts
ehe I'm looking for stock parts since I'm most likely going to be trading the ST in for a 2012+ mustang GT this spring...the ST has been fun and esp with my springs and shocks, but i miss having a V8 and rwd. If no one has a stock one for me, and the issue is the BOV and not the waste gate im sure I can buy yours for a lot less than what’s a new oem one would cost so ill keep you in mind once I know for sure whats throwing the CEL code.
I have both
 

·
Registered
Joined
·
1,715 Posts
I need an internal waste gate that can get me to 30+ PSI on my 6758, Thank you
Have you been drinking again?


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Unfitproduct

·
Registered
Joined
·
198 Posts
Discussion Starter · #9 ·
@Caleb ST1 thanks man gimmy a few days to find some time to poke at the two possible problems, then ill shoot you a PM. Just curious most of the oem replacement wastegates i see for sale say 7psi. its my understanding that the pressure at which a wastegate is rated is usually the max boost you can achieve...am i mistaken?
 

·
Registered
Joined
·
1,715 Posts
No it won’t be enough.

You need turbosmart dualport iwg75 amd 4 port valve and u are good from 7psi to all psi
I have this, had installed, tuner couldn't tune for it...every change in WGDC resulted in varying boost levels that could not be controlled adequately...at least that was my understanding. I have the Mac 4 port BCSV and TS IWG 75 Dual Port WGA (whatever standard spring it comes with) in my garage collecting dust. Swapped back to the EFR 6758 just to get the BT tune dialed in. Maybe one day I'll **** with it again (or sell it?)
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #16 ·
UPDATE,

SO i used a reader tool to reset this code 2 times in the past 3 weeks, and within 2-3 days it popped back up...so i started to look into what could be causing the CEL, overboost points to the wastegate, vacuum leak, or BOV. I have gotten around to checking zero of these, and out of no where after work went to school, then coming out of school started her up and noticed the CEL had cleared it self...now i'm totally baffled...ive been driving it pretty gently keeping boost to around 5-6 psi for the time the CEL has been on since i know the kind of damage overboosting can cause. Now that its self cleared im going to carefully try to see if i can get it to over boost and pop a CEL on command. I just think it was weird that it came back 2 times after clearing it now it self cleared.

SO I either my ST3 comes with a self repair mode, or the sensor that reports boost to the ECU is dirty or flaky...idk any ideas?
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #17 ·
I just wish it would stay healthy and polite like this instead of all the drama recently lol
Great thing about forum drama is its ignorable...so just focus on the good parts of the community :)

PS take note of the drama queens tho to make sure you don't cruse with them or invite them to meets that's when the drama gets real
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #19 ·
what are you using for a tuning device? if its an AP3(or something else that can record/view live data), I wonder what it records as the max boost when this problem happens?
Im using an SPX OTC Autocode, its not a tuner device just a obd2 reader with a few functions. I watched my boost when I had a lit CEL, and i could even on the crappy ford boost estimation gauge def looked like it would snap boost then come back prob 3-4 psi I have no referance of other ST's running a stock MAP so i dont know if its normal. Tonite on the way home once its warmed up im going to boost it hard to see if i can get the code to show up again.
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #20 ·
Another update:

so on the drive home today from work i let the car warm up then did a few pulls to 100+ into 5th gear. Boost seemed stable, and i also backed off and then dropped the hammer a few time watched the boost look like it over boosted a bit and came and settled in at about 12psi to my guess. Also noticed a differnece in gears how much boost it would allow when i was WOT. 5th gear looked like i was getting 16ish, and when i WOT in 6th just under 14 psi. Not sure if the program MAP has differnt boost based on gear ratios and RPM. Good news is no CEL light so my ST3 so far has self repairing properties :)
 
1 - 20 of 44 Posts
Top