Ford Focus ST Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I just got a brand new clutch installed 1 or maybe 2 thousand miles ago. Last night I reversed up a steep driveway and there was some hard clutch slip. Definitely smelled it, but didn't think much of it because it's a new clutch and I'd never slipped the clutch in it before. But this morning, I smelled a faint bit of clutch smell during some normal driving, but the strongest when I first started it up and got going. Is this normal and will go away? Or did my brand new clutch just become toast from only one hard slip? Any advice would be appreciated. I even wonder if I should suspect that the shop put a not-so-new clutch in my car, because I wouldn't have thought that one hard slip could do it in so bad like that. Thanks for your help.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Accidentally posted twice somehow? Sorry, please ignore this thread. Can't figure out how to delete it.
 

·
Administrator
Joined
·
12,221 Posts
I just got a brand new clutch installed 1 or maybe 2 thousand miles ago. Last night I reversed up a steep driveway and there was some hard clutch slip. Definitely smelled it, but didn't think much of it because it's a new clutch and I'd never slipped the clutch in it before. But this morning, I smelled a faint bit of clutch smell during some normal driving, but the strongest when I first started it up and got going. Is this normal and will go away? Or did my brand new clutch just become toast from only one hard slip? Any advice would be appreciated. I even wonder if I should suspect that the shop put a not-so-new clutch in my car, because I wouldn't have thought that one hard slip could do it in so bad like that. Thanks for your help.
Is it an OEM clutch? Details please.

Sounds like you are out of break in. If so then I'd drive here easy for another tank of gas, then do some slippage testing. If it slips while fully engaged, then you have issues.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Is it an OEM clutch? Details please.

Sounds like you are out of break in. If so then I'd drive here easy for another tank of gas, then do some slippage testing. If it slips while fully engaged, then you have issues.
It's not an OEM clutch, I'll have to wait until I get home this evening (long drive) to look at the paper work and hopefully it gives the specific clutch purchased there. Thanks for the advice, I'll take it easy for a while and hopefully the smell goes away.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Is it an OEM clutch? Details please.

Sounds like you are out of break in. If so then I'd drive here easy for another tank of gas, then do some slippage testing. If it slips while fully engaged, then you have issues.
So thankfully the clutch smell did completely go away! Unfortunately, while I know it wasn't OEM, I don't know what brand the clutch was exactly. But I think it may just be an easier clutch to slip than the OEM one was, so I need to be a little more careful than I'm used to. It's working just fine though. Thanks again for your help!
 
1 - 7 of 7 Posts
Top