Ford Focus ST Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have 2013 ST3 with MBRP exhaust, catless downpipe, CX racing FMIC, MBRP intake tube, Cobb air filter, Cobb accessport running stage 3 tune, turbo smart WG actuate. 1 step colder plugs. The car falls on its face at around 4,000 RPM and doesn't seem to run much better than stock down low. I have data logged a 3rd gear pull 2,500 RPM to 5,800 RPM and don't see anything that stands out to me. AFR is around 12:1 WOT most of the run , boost is 21 to 22psi most of the run, Timing is around 8 to 9 degrees in the upper RPM. OAR is .99. I don't Know where the other parameters should be. Anyone good at reading Data logs or have any insight?
 

·
Registered
Joined
·
102 Posts
Got any readings on Fuel Level Sensor Readings or HPFP (High Pressure Fuel Pump) output readings?

How many miles on the Engine?
 

·
Super Moderator
Joined
·
9,548 Posts
Check your spark plug gap.
 
  • Like
Reactions: elyk864

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
Checked boost leaks and everything seems solid. The recirc is stock but the boost was staying 21 to 22 psi and I can here it actuating . How do test the recirc? or is there a data log for that?
 

·
Registered
Joined
·
386 Posts
OAR is .99 + the motor ran good until I put the intake tube and full exhaust on it
Less backpressure with no restriction in the exhaust, I`d start by looking into the WG.
What was the OAR before? Ideally you should see it close to -1, not +1 as you`ve got now.. Check spark plug gap.

One more thing, make sure the OTE pipe isnt touching any of the engine cover pegs or in any way is rattling into anything on engine topside making the knock sensors steal your powa
 
1 - 15 of 15 Posts
Top