Ford Focus ST Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Ok so I traded up to a 2017 and swapped all my parts over from my last ST. Old ST had issues and was about to be out of warranty did not want the big bills. But i digress into the issue at hand. on the old ST my charge temps were around ambient 1-7 above while driving. Now same intercooler on the 2017 charge temps are steady at 14-21 above intake/ambient temps. the real puzzling thing is that after the car sits over night. I get in a turn the car on but not started and my charge temps show 20* above ambient. I have swapped out the sensor on the intercooler with no change. So I wanted to pick the brains of the resident EE guys and see what might be causing it.
 

·
Premium Member
Joined
·
3,726 Posts
Ok so I traded up to a 2017 and swapped all my parts over from my last ST. Old ST had issues and was about to be out of warranty did not want the big bills. But i digress into the issue at hand. on the old ST my charge temps were around ambient 1-7 above while driving. Now same intercooler on the 2017 charge temps are steady at 14-21 above intake/ambient temps. the real puzzling thing is that after the car sits over night. I get in a turn the car on but not started and my charge temps show 20* above ambient. I have swapped out the sensor on the intercooler with no change. So I wanted to pick the brains of the resident EE guys and see what might be causing it.
I want to say there is some miscalculation from OE. I believe when Stratified does their tunes, they account for this and correct it. You'll have to google a bit more to be sure though.
 
1 - 2 of 2 Posts
Top