Ford Focus ST Forum banner
1 - 13 of 13 Posts

·
Registered
2017 Ford Focus ST
Joined
·
724 Posts
Woah! now thats an ugly thing to wake up to.... how much HP and Torque are you pushing? no way that broke on stock figures...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
I still have to drive the car some so I haven't removed it yet. I'll remove it after I get another one. Boomba, I suppose.

It makes lots but of noise if I don't drive it very easy, of course.

Car is stock with a tune...that's it.
 

·
Premium Member
Joined
·
355 Posts
Whoops, well maybe something a little stronger next time?
Do you launch your car often? That's really one of the few stresses that mount really gets abused with.
 

·
Registered
Joined
·
1,763 Posts
I still have to drive the car some so I haven't removed it yet. I'll remove it after I get another one. Boomba, I suppose.
It makes lots but of noise if I don't drive it very easy, of course.
Car is stock with a tune...that's it.
I had a boomba and took it off. Too much NVH.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
I started to notice some vibrations and then they got worse over the next week or so. It was obvious at that point that one of the mounts was broken but I expected that it would be one of the stock uppers, not the FSWerks.

I torqued it down with a torque wrench like I would anything else.

I heard back from FSWerks last weekend but nothing since. I'm just going to order the CPE I suppose.
 
1 - 13 of 13 Posts
Top