Ford Focus ST Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
A week ago i bought a focus ST with 25k miles on it, it has a full exhaust, bov resonator delete and solid steeda motor mounts. When i test drove it it ran good and strong but i started noticing that on boost i feels like it stutters and missfires like hiccup any ideas of wat could it be the problem?? Im new to the ST game lol your help will be apreciated
 

·
Registered
Joined
·
1,016 Posts
Welcome! For starters, make sure you do NOT get into boost at lower RPM. Downshift a gear or two before getting into boost. What rpm are you experiencing this issue at?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Welcome! For starters, make sure you do NOT get into boost at lower RPM. Downshift a gear or two before getting into boost. What rpm are you experiencing this issue at?
Lets say i put it in 1rst gear tru 3rd right tru 3k rpm it stutters right on boost for a and then it clears up
 

·
Registered
Joined
·
1,016 Posts
So it breaks up at 3000rpm? Check spark plug gap and set it to .028"
 

·
Registered
Joined
·
161 Posts
Welcome! For starters, make sure you do NOT get into boost at lower RPM. Downshift a gear or two before getting into boost. What rpm are you experiencing this issue at?
To clarify: I believe TurboGT is referencing LSPI (Low Speed Pre Ignition) i.e. stay out of boost below 3000 rpm in 5th or 6th gears, downshift from those gears before getting into boost.
LSPI is a very real, potential threat to the well being of your engine. As a new owner you should do a Forum search on it and read about it to understand it. Otherwise it could, potentially, destroy your engine, without notice, in just a few seconds
 
1 - 5 of 5 Posts
Top