Ford Focus ST Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
So tonight, drove my daughter to swimming, like a 10-15 km drive, no issues there or on drive back home. On the way to go back to get her, I noticed some hesitation when accelerating to merge onto highway.

Basically at 3000 rpm, on the gas, the boost gauge moves, the revs increase much slower than normal, and with my foot to the floor, and gauge at 3/4, its really down on power.

No idiot lights flashing, no other symptoms, and never had this happen before. I did a 1800km road trip last week and all was well (and fun!).

Only 6400km on her, so calling dealer tomorrow, but just curious if anyone has an idea of what it could be.. my guess is no boost, even though gauge does move.

oh, and no mods at all, she's a leased car.

Thanks!
 

·
Super Moderator
Joined
·
12,420 Posts
If your driving has been on the less aggressive side a KAM (Keep Alive Memory) reset may help. The KAM will remember your driving habits and if you drive around like a grand ma for awhile it will in effect de-tune your car for you. You can disconnect the ground cable from the battery and turn on the headlights to completely drain the electrical system then reconnect.
 

·
Premium Member
2017 Ford Fusion Sport
Joined
·
8,202 Posts
If your driving has been on the less aggressive side a KAM (Keep Alive Memory) reset may help. The KAM will remember your driving habits and if you drive around like a grand ma for awhile it will in effect de-tune your car for you. You can disconnect the ground cable from the battery and turn on the headlights to completely drain the electrical system then reconnect.
Agreed. Easy thing to check just in case
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top