Ford Focus ST Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Okay so I recently bought a 2016 Ford Focus ST with around 30K on the OD . I love the car everything about it and it has. A boomba rear motor mount with matching bracket and a boomba turbo spacer , now since I have been driveing the car it seems as if I’m loosing acceleration/ power in third gear ?I’m really curious as to why maybe the stock intercooler and almost everything else being stock for that matter , it may even be me just babying the accelerator or becomeing a little to familiar with the power already ..... I’m curious why and what others would recommend to me as to getting that good old snap back in my life I’ve only owned the car for about 2 months now and have been talking as good care as possible , I am looking at getting a big intercooler and ap v3 soon hope that will give me the oomffff I need in my life back . Thanks for reading and look forward to all advice and comments ......
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Whats a turbo spacer? Maybe you have a boost leak
It’s a blow off Valve spacer my bad , and also my friend kinda gave all my Intercooler lines a pull and he told me there shouldn’t be leaks .. what ?? I do ??
 

·
Registered
Joined
·
303 Posts
Check your sound symposer. They are prone to leaking from what I read.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Check your sound symposer. They are prone to leaking from what I read.
Wait really lol. I would never have thought that a sound anything would be connected to the turbo or allow any leakes hahaha ! Ty so much , I’m in the process of haveing an Exaust installed so I’ll be sure to look it over . But yea it feels for sure like only gear 3 is loss of power at least that only gear it’s highly noticeable
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
Wait really lol. I would never have thought that a sound anything would be connected to the turbo or allow any leakes hahaha ! Ty so much , I’m in the process of haveing an Exaust installed so I’ll be sure to look it over . But yea it feels for sure like only gear 3 is loss of power at least that only gear it’s highly noticeable
378075
Hey venom this is what Ithought was the blow offvalve spacer .? Is it actually the sound symposer delete and if sozoom in on the grit around it , could it be causing a boost leak
 

·
Registered
Joined
·
303 Posts
That is indeed the sound symposer delete! Ive read some people having issues with boost leaks from having it leak. If it is not properly installed, then it has the potential to leak. A leak of a few lbs of boost can give the perception of loss of power. I would remove it, clean around the intake manifold where it bolts too, and check the o-ring that is fitted inside the boomba.
 

·
Registered
Joined
·
303 Posts
I would also look to see if you have an aftermarket blow off valve. That could be faulty too causing you issues. You can find it behind passenger wheel. Stock ones are plastic and tend to break and fail to hold boost properly after modding.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #10
That is indeed the sound symposer delete! Ive read some people having issues with boost leaks from having it leak. If it is not properly installed, then it has the potential to leak. A leak of a few lbs of boost can give the perception of loss of power. I would remove it, clean around the intake manifold where it bolts too, and check the o-ring that is fitted inside the boomba.
Thanks for the advice brother I will clean her out rite now
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
I would also look to see if you have an aftermarket blow off valve. That could be faulty too causing you issues. You can find it behind passenger wheel. Stock ones are plastic and tend to break and fail to hold boost properly after modding.
I’ll be sure to check there in the morning thanks ? for all the advice venom
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
Stock or not the ?? I know it’s an aftermarket spacer but spring is big long and stiff af . I’m confused to as the person who owned car b4 me also has a symposer delete kit but stock Exaust ?!? Now I feel like this spring is oem and the bushing was just left on by forgetfulness ???
 
1 - 15 of 15 Posts
Top