Ford Focus ST Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,188 Posts
Discussion Starter #1
This question is for you guys familiar with Forscan and the Focccus App. Last night I installed some ST3 headlights I picked up, and made the necessary changes using Focccus and then Forscan to check codes etc. I tinkered with it until I no longer was throwing a "Headlight Fault" CEL.

Everything appeared in working order, no codes, no flickering, all groovy.

This morning, I get in, turn the car on, lights come on as normal A-OK. I normally run with my fogs on when my lights are on, and since I was messing with everything the fogs got turned off ... so I flipped them on ... and boom, flickering headlights. Turned them back off, but still flickering. I gave up, turned them off and went to work, and here I sit wondering what went wrong.

My headlight type was set to Alternate HID, and I thiiiink I had it set to no dipped. I can't remember exactly what I settled on to keep it from coding.

Thoughts?
 

·
Registered
Joined
·
293 Posts
We installed ST2/3 lights on my buddies '18 ST1... I changed it to Xenon headlamps not HID. You'll always get an error code because the headlight control module isn't present. Try that setting and report back!

Sent from my IN2020 using Tapatalk
 

·
Registered
Joined
·
2,086 Posts
You'll always get an error code because the headlight control module isn't present.
does that apply to the preface lift cars that do not have the adaptive headlights? I am just asking, no clue about the control module but curious if it applies to the OP if they have a '14 with the lights that do not swivel. Prefacelift used a cornering light with the HIDs instead and iirc, the cornering lights cant be programed aka they wont do anything when swapping in st3 headlights. I think you are right about the Xenon part though
 

·
Registered
Joined
·
293 Posts
Yes it's still applicable because even the prefacelift lights had auto-leveling which is another feature controlled by the headlight control module


Sent from my IN2020 using Tapatalk
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #5
I should specify, I do still get a communication error DTC, but no CEL for that which I am fine with. I was working to resolve the CEL and alert when I start the car up.
 

·
Registered
Joined
·
293 Posts
I should specify, I do still get a communication error DTC, but no CEL for that which I am fine with. I was working to resolve the CEL and alert when I start the car up.
You're not going to be able to get rid of that unless you add a headlight control module to the vehicle.

Sent from my IN2020 using Tapatalk
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #7
You're not going to be able to get rid of that unless you add a headlight control module to the vehicle.

Sent from my IN2020 using Tapatalk
Well, currently I am not getting that CEL, like I said. And last night I did have stable headlight function. But I didn't try it with the fogs last night. As soon as I switched them on this morning it was flicker city.
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #9
Its basically doing the normal flickering that happens when you haven't switched to HID in the programming. I will need to do some testing when I get home to see if there is causation with the fog lights, whether restarting resolves, whether they were ever really stable at all, etc. Also need to verify the settings I was using. Then we can start to really troubleshoot.
 

·
Registered
Joined
·
155 Posts
Just a heads up, using fog lights when they are t needed hurts your night vision. Shouldn’t be using dogs unless there is fog.

Do all the lights ground to the same place?
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #11
Ok, I got another crack at it. Switched it xenon, works perfect. CEL is on, unfortunately as you said would happen. Turns out, I never started the car... they worked fine as is until I started, then it was flicker.


Sent from my iPhone using Tapatalk
 
1 - 11 of 11 Posts
Top