Ford Focus ST Forum banner
1 - 11 of 11 Posts

·
Registered
2016 ST1 Oxford White, Gen2 GTX3076R Turbo
Joined
·
115 Posts
Discussion Starter · #1 ·
I guess the issue with the clunking suspension resolved itself. No idea what would have caused it or if it's even fixable.
392490
392491
 

·
Registered
Joined
·
477 Posts
What coil overs are these? I’m glad you didn’t hurt!
 

·
Registered
2016 ST1 Oxford White, Gen2 GTX3076R Turbo
Joined
·
115 Posts
Discussion Starter · #6 ·

·
Registered
2016 ST1 Oxford White, Gen2 GTX3076R Turbo
Joined
·
115 Posts
Discussion Starter · #7 ·
Gave eibach a call and they did say they are going to have me sent them in to try to fix. Probably won't work but at least they will look at it
 
  • Like
Reactions: Smokin' Joe

·
Super Moderator
Joined
·
9,817 Posts
Gave eibach a call and they did say they are going to have me sent them in to try to fix. Probably won't work but at least they will look at it
Well, they can probably rebuild it; will most likely be all new parts to get it done. They stand behind their products; rebuilt one of my b8's when the seals blew out.
 

·
Registered
Joined
·
708 Posts
Well, that calls for some Fortune 500's or 510's... No way to fix that kind of broken. Either rebuild, or buy something else.

I hope you get taken care from Eibach. I have no experience with them, but this is the 1st failure I've seen like that on coilovers.

Were you doing a stage rally or something equally abusive? Sorry, but I have to ask how the eff that happened...
 

·
Registered
2016 ST1 Oxford White, Gen2 GTX3076R Turbo
Joined
·
115 Posts
Discussion Starter · #10 ·
Well, that calls for some Fortune 500's or 510's... No way to fix that kind of broken. Either rebuild, or buy something else.

I hope you get taken care from Eibach. I have no experience with them, but this is the 1st failure I've seen like that on coilovers.

Were you doing a stage rally or something equally abusive? Sorry, but I have to ask how the eff that happened...
Driving on the road, was going to do some shopping. Car has never been off road or tracked. Coilovers rebuilt in February. I put them on after the snow melted.

Really have no idea what would have caused this. Tires don't rub as I put wheel spacers on but even then they had about an inch of clearance.
 
  • Like
Reactions: Smokin' Joe
1 - 11 of 11 Posts
Top