Ford Focus ST Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hey Gang,

I've been having some weird issues when it comes to my LTFT lately (or at least since I've been keeping an eye on that monitor since last week). So, the car is seemingly running fine, but I will randomly get the P2096 and also P0171 very occasionally. So for the last 3-4 days, the LTFT has been holding steady around +6-10%, but today just randomly decided to spike to +25% while I was about a block from home. Under load it's sticking around normal levels, but it spikes at idle and I can't seem to find any leaks or other obvious culprits. So far I've tried the starter fluid leak check around and seals on the manifold, replaced my upstream O2 sensor, and replaced the stripped intake clamp at the turbo.

It's a 2013, about 200k, Mishi intake, Mishi Intercooler kit, catless downpipe with a L defouler, 3" MBRP exhaust, stage 1 Cobb map.

Just stumped on why it seems to come and go, and was hoping you guys might have some insight. I can run some data logs to and from work tomorrow if that would help.

Thanks,
Nick
 

· Super Moderator
2014 ST3. Garrett GTX2860R Gen 2. FBO
Joined
·
9,383 Posts
When you installed the downpipe, did you reuse the fire ring or did you buy new?

Have you inspected the Vband at the downpipe to see how tight it is?
 

· Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
When you installed the downpipe, did you reuse the fire ring or did you buy new?

Have you inspected the Vband at the downpipe to see how tight it is?
You know, that's a great question and I can't remember to be completely honest. I want to say that I might have reused it, and I'm not sure it it was replaced when the DP was off for a turbo blnket fitting ( I work for Mishi so we were doing the test fit on our sample). I did pick up a new ring the last week since I did originally intend on pulling the DP, but I didn't get a chance to get that far. I did check the V-band last weekend and it was definitely secure though. I noticed today that it's only at idle and off throttle that the LTFT spikes. Cruising down 95 this morning it doesn't go over 10.9% (still a little too high) when on throttle or under boost, but it jumps to 28% when I let off.

-Nick
 

· Vendor
Joined
·
979 Posts
I found in the Fiesta ecu update I pulled that the downstream oxygen sensor had a bias table like the focus rs. My assumption is the focus st may as well.

Just a thought, give this a try and do a kam reset after installing and see if you notice any difference. This is for the downstream sensor only and to replace your defouler.

 

· Super Moderator
2014 ST3. Garrett GTX2860R Gen 2. FBO
Joined
·
9,383 Posts
Okay, so scratch that. You have me thrown off now. The trims are indicating a vacuum leak, which you already tested for with the alternative fuel.

Did you do this test with the engine warm? If so, try it again but when it's stone cold, and also focus around the throttle body and symposer area as well. Sometimes those gaskets shrink more when cold.

Speaking of symposer, yours is deleted, right?
 

· Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
I found in the Fiesta ecu update I pulled that the downstream oxygen sensor had a bias table like the focus rs. My assumption is the focus st may as well.

Just a thought, give this a try and do a kam reset after installing and see if you notice any difference. This is for the downstream sensor only and to replace your defouler.

Gotcha! I'll give that a try. My defouler was looking pretty rough, too, so I was thinking about replacing that anyways. I'm not super familiar with the downstream stream bias table, though. I'm assuming that means it has more say in the fuel mixture?

Okay, so scratch that. You have me thrown off now. The trims are indicating a vacuum leak, which you already tested for with the alternative fuel.

Did you do this test with the engine warm? If so, try it again but when it's stone cold, and also focus around the throttle body and symposer area as well. Sometimes those gaskets shrink more when cold.

Speaking of symposer, yours is deleted, right?
I did test when it was warm, basically right after I came out of the AutoZone with the starter fluid. I'll give the cold test a try tomorrow. And yep sound symposer was deleted before I got the car

Thanks!
-Nick
 

· Super Moderator
2014 ST3. Garrett GTX2860R Gen 2. FBO
Joined
·
9,383 Posts
So this has been happening since last week. Have you been on the same tank since last week?

High ethanol content shows up as positive trims.
 

· Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
So this has been happening since last week. Have you been on the same tank since last week?

High ethanol content shows up as positive trims.
I last filled up Monday morning, and then this evening both with 93. I think I was at about a quarter tank when the trim spiked. The monday fill up was at the local Karco, and then today was Wawa because I'm a heathen haha. I'll try a top tier place for the next tank too

-Nick
 
1 - 10 of 10 Posts
Top