Ford Focus ST Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I got about 10,000 dollars work done at ford dealership and they give me my car back saying this plug was already like this. And they said it's a airflow sensor and that I don't need it because I have aftermarket performance parts and the tune I have doesn't require it. Is it true or they trying to BS me? I remember replacing my stock intake with the aftermarket cold air intake and I'm pretty sure there were no wires I left disconnected.
Automotive tire Hood Black Motor vehicle Automotive design

Vehicle Automotive tire Motor vehicle Automotive design Automotive fuel system
 

·
Registered
Joined
·
1,244 Posts
Yeah, I also had to ask one day... Looks like the sound symposer connection to me, also. If you have a symposer delete then don't worry about it (other than a little anti-corrosion gel & tape on that loose harnesses, just in case).

$10k is alot... Did you have an engine and transmission replacement??
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Ddfred and smokin Joe.
So the story begins with me going to get an oil change at a drive through valvoline instant oil change. They tell me I'm good to go and I drive off and the motor starts screeching loud af at about 10 min in. So I'm like wtf I get out check the oil and NO OIL was put back in after they drained it. So the next day took it to ford dealer and basically needed a new motor and turbo assembly. 4 weeks and 10 k later I got it back. Now the dam power steering doesn't work and I had to buy a new batter because the dealership wanted to charge me close to 300 for a new one installed. 🙄 I asked them why they couldn't see why the powers steering wasn't working because I didn't buy a new battery from them and the battery in the car was dead so they couldn't diagnose it. Terrible customer service.
 

·
Super Moderator
Joined
·
10,518 Posts
Ddfred and smokin Joe.
So the story begins with me going to get an oil change at a drive through valvoline instant oil change. They tell me I'm good to go and I drive off and the motor starts screeching loud af at about 10 min in. So I'm like wtf I get out check the oil and NO OIL was put back in after they drained it. So the next day took it to ford dealer and basically needed a new motor and turbo assembly. 4 weeks and 10 k later I got it back. Now the dam power steering doesn't work and I had to buy a new batter because the dealership wanted to charge me close to 300 for a new one installed. 🙄 I asked them why they couldn't see why the powers steering wasn't working because I didn't buy a new battery from them and the battery in the car was dead so they couldn't diagnose it. Terrible customer service.
So is the oil change place taking responsibilty for the engine install?
 

·
Registered
Joined
·
4 Posts
Ddfred and smokin Joe.
So the story begins with me going to get an oil change at a drive through valvoline instant oil change. They tell me I'm good to go and I drive off and the motor starts screeching loud af at about 10 min in. So I'm like wtf I get out check the oil and NO OIL was put back in after they drained it. So the next day took it to ford dealer and basically needed a new motor and turbo assembly. 4 weeks and 10 k later I got it back. Now the dam power steering doesn't work and I had to buy a new batter because the dealership wanted to charge me close to 300 for a new one installed. 🙄 I asked them why they couldn't see why the powers steering wasn't working because I didn't buy a new battery from them and the battery in the car was dead so they couldn't diagnose it. Terrible customer service.
Dude, insane! I was about to ask the same question as @ddfred, what did the valvoline oil change place said or did from this situation?
 

·
Registered
Joined
·
54 Posts
Ddfred and smokin Joe.
So the story begins with me going to get an oil change at a drive through valvoline instant oil change. They tell me I'm good to go and I drive off and the motor starts screeching loud af at about 10 min in. So I'm like wtf I get out check the oil and NO OIL was put back in after they drained it. So the next day took it to ford dealer and basically needed a new motor and turbo assembly. 4 weeks and 10 k later I got it back. Now the dam power steering doesn't work and I had to buy a new batter because the dealership wanted to charge me close to 300 for a new one installed. 🙄 I asked them why they couldn't see why the powers steering wasn't working because I didn't buy a new battery from them and the battery in the car was dead so they couldn't diagnose it. Terrible customer service.
VIOC paid for replacements?
 

·
Registered
Joined
·
1,244 Posts
So now let's go back a bit. I had a 2014 ST1 with similar conditions, and after an engine replacement it was basically all about bad grounds and harnesses...

Let's get the year, mileage, mods, and any other history of your car that's available.

This might not be as simple as you would hope... 😣
 

·
Super Moderator
2014 ST3. Garrett GTX2860R Gen 2. FBO
Joined
·
5,377 Posts
Yes thats the symposer plug. You no longer have that system installed. As mentioned before, dielectric grease the plug and seal it up with tape or something to keep dirt out.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #13 ·
In the mornings when I go to work I start the car up and the power steering works. About 15 min into the drive it randomly goes out. After work I start the car up and powersteering works again until about 15 min on the way home. And that's how it's been for a couple of weeks now. Anyone know why? Or had similar issues?
 

·
Registered
2015 Ford Focus ST
Joined
·
537 Posts
So any chance this is a cracked fuse issue? Sometimes it's good as things heat up it opens.
You mentioned battery replacement. Mega fuses are a bit weak. I'd look there.
 

·
Registered
2015 Ford Focus ST
Joined
·
537 Posts
Maybe these electrical diagrams will help you sort it out.
 

·
Registered
2015 Ford Focus ST
Joined
·
537 Posts
The problem I had was when I replaced the battery I cracked the fuse. They are very delicate.
 
  • Like
Reactions: JOKR-ST

·
Registered
Joined
·
9 Posts
Discussion Starter · #18 ·
I fixed the problem... took it to a shop so they could check all of the wiring harness connections for the power steering rack and they took it into the bay and were like yeah, your rack and pinion assembly needs to be replaced. Computer not communicating with the rack. Ao I'm like did they just plug it into the dam code reader? Cuz I could have told them that. I'm fed up at this point because i literally just paid the guy 85 bucks to tell me the powersteering isn't working. 😭 basically. But I'm like **** that. The guy told me it's about 2600 to get it replaced.. so I go home and let the car sit for a few hours. I'm like ok. It's nice and cool now so I start it up and wow the power steering works. Just like always. So I drive for about 15 min and it stops working. So I get it home and pop the hood get my leaf blower and a fan and put them full blast into the engine bag. Even poured some water on the power steering rack and it could down super fast. Turned the car back on and.... it worked again. So now I'm like wtf. I get some sheet metal and fab up my own heat shield and wrap it around the cat that's about 4 inches away and wrap some sheet metal around the power steering rack and boom... haven't had it stop working in 3 days!
 

·
Super Moderator
Joined
·
2,252 Posts
I fixed the problem... took it to a shop so they could check all of the wiring harness connections for the power steering rack and they took it into the bay and were like yeah, your rack and pinion assembly needs to be replaced. Computer not communicating with the rack. Ao I'm like did they just plug it into the dam code reader? Cuz I could have told them that. I'm fed up at this point because i literally just paid the guy 85 bucks to tell me the powersteering isn't working. 😭 basically. But I'm like **** that. The guy told me it's about 2600 to get it replaced.. so I go home and let the car sit for a few hours. I'm like ok. It's nice and cool now so I start it up and wow the power steering works. Just like always. So I drive for about 15 min and it stops working. So I get it home and pop the hood get my leaf blower and a fan and put them full blast into the engine bag. Even poured some water on the power steering rack and it could down super fast. Turned the car back on and.... it worked again. So now I'm like wtf. I get some sheet metal and fab up my own heat shield and wrap it around the cat that's about 4 inches away and wrap some sheet metal around the power steering rack and boom... haven't had it stop working in 3 days!
This sounds for all the world like a failed solder joint. Your heat wrap solution may for for now, but its probably going to fail for good at some point. I'd use this bought time to track down a cheap rack.
 

·
Registered
2013 Ford Focus ST1
Joined
·
1,947 Posts
This sounds for all the world like a failed solder joint. Your heat wrap solution may for for now, but its probably going to fail for good at some point. I'd use this bought time to track down a cheap rack.
Agreed. If the circuit board can be removed from the rack it MIGHT be possible to reflow the solder joints…..
 
1 - 20 of 24 Posts
Top