Ford Focus ST Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 · (Edited)
I was changing trans fluid and I was filling it from the top bolt under the shifter arm. I touched the wires that connect to the front of the battery box. It made sparks after that I disconnected the battery ground. when I started the car the power steering was gone and a message on the screen said "power steering failure - service required".
Steering is rock hard and it's almost impossible to drive. When my speed sensor went bad traction control, abs, and power steering were gone but it didn't show any messages and I don't remember it being that difficult to steer.

Any help would be appreciated.

Solved: it was a mega fuse.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #5 ·
I checked F40 it seems ok, I also put the F39 fuse in the F40 slot and vice versa nothing changed so it's not a fuse :(
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #9 ·
I lived without power steering before, it was a bad speed sensor which meant power steering was reduced or fully off, now it's almost impossible to turn the wheel maybe because I have 245 Michelin PS4S.
The Dealer next to my house has no electricity and I don't want to tow the car to another dealer just yet because most of them just throw parts at the issue until something sticks.
going from P.S. to none. Oh boy, Parking must suck sometimes. Sorry to hear this happened; have you taken it to the dealer?
 
1 - 20 of 27 Posts
Top