Ford Focus ST Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter · #1 ·
Hi guys, I changed my spark plugs to one step colder yesterday and after 15 miles of driving I got a CEL with the P04DB code. Does anyone know what could be causing this?? I have a 2015 with 24,000 miles.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Craig Waddell

·
Registered
Joined
·
183 Posts
Did you reconnect your PVC line. This code is usually PVC disconnected or crankcase ventilation.
 

·
Registered
Joined
·
104 Posts
Discussion Starter · #3 ·
The one going to the intake tube? I never disconnected it. However, I have the Cobb intake and I never really felt confident about that connection. I pushed it in hard but never heard a click...there's no modification needed on that hose to fit it on right?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
181 Posts
Maybe. I have a Steeda intake for the older focus and for the 15 they changed the hose size and went bigger. I believe Cobb sells an adapter for it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
104 Posts
Discussion Starter · #5 ·
Maybe. I have a Steeda intake for the older focus and for the 15 they changed the hose size and went bigger. I believe Cobb sells an adapter for it.


Sent from my iPhone using Tapatalk
Yeah I have the right adapter but that clip on the pcv hose is a little weird to me


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
104 Posts
Discussion Starter · #8 ·
It's just a push clip. It's kind of stubborn but just push it really hard until you hear a click


Sent from my iPhone using Tapatalk
Yep I feel dumb now. Pcv hose popped off the back of the intake. I just never pushed it in hard enough and I guess it took a couple of hundred miles to wiggle out.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Choppa
1 - 8 of 8 Posts
Top