Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
2016 OW ST3 basically stock.... minus the Steeda Fusion FMIC
Joined
·
23 Posts
Discussion Starter · #1 ·
Hey all I had a question about Intercoolers. I have a Steeda FMIC off a 2.0 Fusion laying around. I was curious if anyone has tried stuffing one of those on an ST?? I have no idea if it'll fit but I'll probably give it a try and post updates as I experiment lol. If anyone knows anything about this I'd appreciate the feedback!
Road surface Asphalt Plant Waste container Font

Automotive tire Motor vehicle Road surface Asphalt Automotive design
 

·
Registered
2016 OW ST3 basically stock.... minus the Steeda Fusion FMIC
Joined
·
23 Posts
Discussion Starter · #5 ·
You could probably zip tie it up for tentative mounting, and just use large hose clamps to mount it to the crash bar. Intercooler piping should be flexible enough to fit, only concern after that is whether the pressure sensor plugs in and works properly lol.
I think it could be done, definitely post up your results!
Will do!
 

·
Registered
2016 OW ST3 basically stock.... minus the Steeda Fusion FMIC
Joined
·
23 Posts
Discussion Starter · #6 ·
Quick update:
Welp took the bumper off to discover I bought a demoded car🙁 and it had the factory intercooler reinstalled w/ zipties. Aaaand the mounting points were broken off.
On a positive note the Fusion intercooler fits, though it is slightly more narrow than that of the Focus Although obviously the mounting doesn't line up w/ the factory points.
Soooooo zip ties it is!
Automotive tire Motor vehicle Asphalt Tread Wheel
 

·
Registered
2016 OW ST3 basically stock.... minus the Steeda Fusion FMIC
Joined
·
23 Posts
Discussion Starter · #11 ·
Just beware that the temptation to turn temporary fixes into permanent ones is very real. All it requires is for you to forget about it, until something goes wrong lol.

How about how it functions? You're not popping any codes and are holding boost?
Very true! I'll have to come up with a couple little brackets when I have more time.

It seems to function fine, I took her out and dropped the hammer a few times! She seems to run and hold boost just fine w/ no check engine light! I'll have to check my IATs when I get a chance
 
1 - 6 of 6 Posts
Top