Ford Focus ST Forum banner

101 - 120 of 142 Posts

·
Registered
Joined
·
73 Posts
Sorry for placing a couple of orders and canceling them in the middle of the night, lol! I didn't have the fogs and reverse lights in my first order, then placed a new order with the 6K fogs and reverse lights. I'm glad I saw this picture though and was able to see the color difference in the factory lights and the 6K. I canceled once more and bought the 5K instead! I can't wait to get everything!
 

·
Vendor
Joined
·
485 Posts
Discussion Starter #102
Sorry for placing a couple of orders and canceling them in the middle of the night, lol! I didn't have the fogs and reverse lights in my first order, then placed a new order with the 6K fogs and reverse lights. I'm glad I saw this picture though and was able to see the color difference in the factory lights and the 6K. I canceled once more and bought the 5K instead! I can't wait to get everything!
Thank you for ordering with us!

Looking forward to seeing pictures with everything installed on your FoST!

Nick C.
 

·
Registered
Joined
·
73 Posts
Awesome C/S guys, thanks for taking care of me!

Factory vs HP50


Factory vs SMF1


Factory vs. HP5


Pure White 5K XML2 Fogs


LED Reverse and Cargo Lights


I'm super impressed with the quality of everything: the construction, performance, packaging and customer service! I will be back to order more LEDs for my other cars! I have my eyes on the LED kit for our Fusion.
 

·
Registered
Joined
·
24 Posts
Recently installed the XML2s in my 2016 ST and honestly I am pretty dissapointed with the fitment.

When spinning the LEDs to lock them in they seem to unspin quite easily. To the point where I am worried they will back out from hitting bumps on the road/

Also, on the drivers side, the back of the LED housing touches the cars ECU case. I am worried that this could wear a hole in the ECU case over time.

Anyone else have these issues, or did I install them wrong? (I don't think I did, as I really don't see how it could be done any other way.)
 

·
Vendor
Joined
·
485 Posts
Discussion Starter #106
Recently installed the XML2s in my 2016 ST and honestly I am pretty dissapointed with the fitment.

When spinning the LEDs to lock them in they seem to unspin quite easily. To the point where I am worried they will back out from hitting bumps on the road/

Also, on the drivers side, the back of the LED housing touches the cars ECU case. I am worried that this could wear a hole in the ECU case over time.

Anyone else have these issues, or did I install them wrong? (I don't think I did, as I really don't see how it could be done any other way.)
@cbr600rr,

They are a direct bulb replacement, but it may help to swap the red O-ring on the XML2 out with the factory incandescent bulb's for a better fit into the factory bulb holder. As far as length is concerned, it's due to the heatsink requirements of the powerful XM-L2 LEDs that the XML2 utilizes.

If you have any questions or need any support, please feel free to contact us: (314) 205-3033

Nick C.
 

·
Registered
Joined
·
83 Posts
I'm having an issue where one bulb is not lit all the way. I've had them for a couple of months but just noticed it now. Is that common for luxeon housing LEDs?
 

·
Registered
Joined
·
73 Posts
Am I missing something? I don't see the xml2's on your website anymore for the 2015+ STs (I have the 2017). I have the factory HIDs so was hoping to get the 5000K to match (possibly 3K...haven't decided between yellow or white to match the headlights). Link perhaps?
 

·
Premium Member
Joined
·
3,470 Posts
Am I missing something? I don't see the xml2's on your website anymore for the 2015+ STs (I have the 2017). I have the factory HIDs so was hoping to get the 5000K to match (possibly 3K...haven't decided between yellow or white to match the headlights). Link perhaps?
They are discontinued, replaced with the SLF bulbs. I have some on the way.
 
101 - 120 of 142 Posts
Top