Ford Focus ST Forum banner

1 - 6 of 6 Posts

·
Super Moderator
2017 Ford Fusion Sport
Joined
·
8,194 Posts
Discussion Starter · #1 ·
2014 ST3

So last week I randomly got a headlight fault error which annoyingly popped up like 4 times in 35 miles even though my Headlights were in fact on. So I got home and restarted the car and Headlights were on fine. Never checked fog lights and Google search said the headlight fault thing was normal and usually a bug/glitch. Anyway today I installed my MBRP catback on a lift and drove a little since then. Looked at the front of my car while it was running an hour ago and my fog lights are off...and stay off no matter how many times I hit the button or flip the switch. Checked the fog light fuse, looks fine. What in the heck is going on? Anyone else have this issue or know what it could be? Haven't seen yet headlight error since Saturday when it blinked on a moment again.
 

·
Premium Member
Joined
·
131 Posts
When you turn them on does the fog light icon show up on the dash or does it not even know the button was pressed, If its on have you checked the fog light plug, it may have been loose from a previous bumper removal.
 

·
Super Moderator
2017 Ford Fusion Sport
Joined
·
8,194 Posts
Discussion Starter · #3 · (Edited)
When you turn them on does the fog light icon show up on the dash or does it not even know the button was pressed, If its on have you checked the fog light plug, it may have been loose from a previous bumper removal.
Yes, the icon does in fact light up on the dash...which means I'll be removing my lower facia I'm sure to check the plug. Thank you for the suggestion, still open for other suggestions. The fog light harness plugs in on the driver side, correct?

Oh, and would a loose plug cause the error message?
 

·
Premium Member
Joined
·
131 Posts
Im not sure if it would cause the error message but I've had that message pop up before also.
When I did my FMIC I didn't connect the fogs good and they were flickering.
Yes the clip is on the drivers side not to far from the light.
 

·
Super Moderator
2017 Ford Fusion Sport
Joined
·
8,194 Posts
Discussion Starter · #5 ·
Im not sure if it would cause the error message but I've had that message pop up before also.
When I did my FMIC I didn't connect the fogs good and they were flickering.
Yes the clip is on the drivers side not to far from the light.
Thanks for the help man, not sure when I'll be free to check that but I'll be sure to post back.

Again, if anyone has any other suggestions/ideas they're appreciated.
 

·
Super Moderator
2017 Ford Fusion Sport
Joined
·
8,194 Posts
Discussion Starter · #6 · (Edited)
When you turn them on does the fog light icon show up on the dash or does it not even know the button was pressed, If its on have you checked the fog light plug, it may have been loose from a previous bumper removal.
Great news, you were correct. Took the drivers side headlight out and 2 seconds with the flashlight showed me the harness just hanging there. Plugged it in and bam. Easy fix. Thanks a ton man!

Oh and @DailyDriver since you still haven't seen my engine bay I said about before I attached another shot, and threw in one showing another Ford in the family haha
 

Attachments

1 - 6 of 6 Posts
Top