Ford Focus ST Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I recently installed a catless downpipe on my 2014 ford focus st and when i started her up she started to idle rough dropping to 700 or 500 rpm and jumping back up to 1500. sometimes when i drive from a stop the engine drops very low rpm and sounds like it’s about to shut off. anyone have any clue what’s going on? is my car running to lean or is it to rich?
Mod list: (AWE catback exhaust) (catless downpipe) I do not have a tune
 

·
Super Moderator
Joined
·
1,636 Posts
I recently installed a catless downpipe on my 2014 ford focus st and when i started her up she started to idle rough dropping to 700 or 500 rpm and jumping back up to 1500. sometimes when i drive from a stop the engine drops very low rpm and sounds like it’s about to shut off. anyone have any clue what’s going on? is my car running to lean or is it to rich?
Mod list: (AWE catback exhaust) (catless downpipe) I do not have a tune
Have you had the purge valve replaced at any point? Usually this is a good indicator it's dying.
 

·
Registered
2016 ST2, Absolute Black, Monster FMIC, Turbosmart BPV, ALEX' Shift Bushings,PCV-OCC, Innovative RMM
Joined
·
1,605 Posts
Did you use new exhaust gaskets and clamp? Turbo side could be leaking and cause erratic O2 readings and behavior.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Did you use new exhaust gaskets and clamp? Turbo side could be leaking and cause erratic O2 readings and behavior.
i did not use a new clamp and i thought that was the problem too but i double check and it looked closed and tight. any specific way to test for leaks there?
 

·
Super Moderator
Joined
·
10,074 Posts
i did not use a new clamp and i thought that was the problem too but i double check and it looked closed and tight. any specific way to test for leaks there?
Have you checked for codes? Did you replace the o2 sensors when you did the down pipe? They are easily damaged.
 
1 - 7 of 7 Posts
Top