Ford Focus ST Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1 (Edited)
Hi everyone my name is Zack. As this is my first thread I will start off with a little bit about my car.

2015 OW Focus ST3

Current mods:

Depo Racing Beast FMIC
Velossatech Bigger mouth intake
Greddy cat back exhaust
3" catless downpipe
Cobb AP3 w/ Stratified Tune
Steeda short throw shifter and shift plate
Yellow speed racing coilovers
JBR sound symposer delete

Okay so now my problem. Everything has been running smooth with all of my mods up until today. Last week my catless downpipe was installed on Wednesday. I uploaded my tune and hit the road for a 1400 mile road trip. She ran smooth the whole trip without a single hiccup. I got home Monday morning and drove around town with no issues all day. This brings us to today, I am driving to work this morning and 3/4 of the way there my battery light pops on. Nothing seemed amiss and the car was, and still seems to be, running fine. I read the codes and this is what I got:

20160705_183314.jpg 20160705_183321.jpg 20160705_183348.jpg

After work I tried to research what could be causing these codes. I checked everything that could be checked, except to get the car up and check the downpipe, cleared the codes multiple times and all is well. I tried pulling the fuse for the AGS as well but that did nothing and it has not caused any issues up to this point.

So in conclusion I hope this all makes sense and that someone can help give me an idea of what is causing these codes. Any advice and questions are welcome and appreciated.

Afrozack
 

·
Registered
Joined
·
420 Posts
There are circuits between the generator/PCM and AGS/PCM that are common. I cant remember if its power, ground or a LIN communication circuit. It could be a combination of the three. But if the generator connector or AGS connector are not fully seated or disconnected, the PCM will no longer be able to communicate with either. So if there are no loose connections at the AGS or generator, there is a wire that got pinched or broken during the installation process.
 

·
Registered
Joined
·
420 Posts
Well that depends.

What is a defouler?

Never heard of this.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #5
@tpiechow If I am not mistaken the defouler goes on to the o2 sensor bung of the downpipe to fool the sensors to think there is still a cat there so it does not throw a code.
 

·
Registered
Joined
·
420 Posts
Ah alright, then no it's not related. This is an electrical issue.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #7
Update:

The battery light has gone off and after a tune update the AGS codes have also been eliminated. She is running like a champ still and all is well.
 

·
Registered
Joined
·
45 Posts
My basically stock 16 ST had the same codes come up on and off for a week. I didn't clear them or do anything, and the battery light has not been on for over a month.
 
1 - 8 of 8 Posts
Top