Ford Focus ST Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
All,

I am currently running all of Cobb's Stage III parts and OTS tune on my 2014 ST and failed the state inspection due to the o2 sensor not ready and heated o2 sensor not ready? Been checking the threads and seems like there is a couple of options. Some say uninstall the tune and retry or install a defouler? Anyone else have this problem and if so what did you do to pass?

Any help would be greatly appreciated!
 

·
Registered
Joined
·
629 Posts
use a defouler and make sure the tune doesnt disable the rear o2 sensor. if rear o2 is disabled within tune, you will fail emissions.

google ford drive cycles.
 

·
Registered
Joined
·
163 Posts
A defouler would be the best way (my opinion) as that's what's always worked for me when I get emissions done. Install the defouler and swap to a map that would have the stock downpipe and grandma it until after your test then swap to you stage 3 map and drive normal again.


Sent from Dr. Lights lab
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
SO finally got my ST to pass inspection this morning and I thought I would share what I had to do just in case someone else runs into this same problem. First let me say Cobb was absolutely no help at all! I installed the Vibrant J defouler then I switched to the Cobb Stage II OTS map on the AccessPort. I had to drive about 100 miles to get the O2 sensor ready signal. It was nice to be able to drive and watch the codes change on the Accessport. Now that is done I can switch back to the Stage III tune until next year or until I switch to other tune, maybe Mountune or Panda.
 
1 - 4 of 4 Posts
Top