Ford Focus ST Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
So about two months ago i started doing research and started piecing it together....so far i have this:
374926
374928
374930


more items have been wired however I have a problem....
374931

Where do I attach the pressure switch? I know it goes on the vacuum line and the one i found is hard plastic but supposedly i can tee it off... I see a few youtube videos but all of them seem to skirt the pressure switch....any help would be greatly appreciated ....
Before anyone goes out and calls me cheap etc, I enjoy DIY keeps my hands busy, and there is a lot more satisfaction from doing something on your own...or maybe i'm just a old fk.
 

Attachments

·
Registered
Joined
·
32 Posts
I used a symposer delete kit with a tap as a vacuum source. You can cut the stock vacuum hose and tee it off if you know which one to cut. Btw, I had a boost switch just like your on my Subaru. Now I use a cheaper one and protect it with a check valve.
 

·
Registered
Joined
·
56 Posts
What is that pressure switch? What are you using for a nozzle?
When I built a WMI kit for my supercharged Dakota, I used an adjustable Hobbs switch and a nozzle from an oil burning home heater.
 

·
Registered
Joined
·
32 Posts
It is a pressure switch on Amazon, search for: SNS QPF-N1 1/8 Inch Male Thread Pneumatic Adjustable Diaphragm Type Pressure Switch Normally Open and Closed Integrated. It used to cost me $11, now it is $18. For nozzle, I use Devil's own, the smallest one that they sell.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #7
Nozzle is devils own do3 or something....the switch is the same switch devils own uses nason sq2
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8 (Edited)
The gold on in the pic is from the turbo mirage page at 100 psi was about 330ml a second but decided to go the devils own route with the nozzle...I have the dumpiest delete so I just run the line to the natural vac slice it hook up the switch and cap the solenoid?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #9
finally hooked it up, im in the test phase, so I set my switch to 15psi. I took the car for a spin the pump kicked on, but once the psi dropped it didnt shut up. I hooked it up to the hot of the turbo, on top of the solnoid based off a few videos I saw on youtube....any thoughts?
 

·
Registered
Joined
·
32 Posts
It must be the pressure switch does not release. You could hook up a pressure gauge with a buzzer or light to check the pressure switch.
 
1 - 11 of 11 Posts
Top