Ford Focus ST Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Alright guys so as you guys know I have a big Turbo upgrade and I just recently installed the depo intercooler. Cobb accessport shows temps are ambient but never go above 8 degrees under full throttle in 3 or 4th gear, I'm sure a tune adjustment needs to be done. I'm currently on the 7th revision with stratified. What I have noticed is that I'm not getting as much boost as I was before with the stock intercooler. Is this normal? Car felt faster with the original intercooler. Any input would help

Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
378 Posts

·
Registered
Joined
·
378 Posts
Did you read the blog??

Sent from my LG-H918 using Tapatalk
 

·
Registered
Joined
·
378 Posts
Read some more


Sent from my LG-H918 using Tapatalk
 

·
Registered
Joined
·
77 Posts
Discussion Starter #6
Did you read the blog??

Sent from my LG-H918 using Tapatalk
Yes. "What you will see is that the ECU will vary the boost pressure to target the same load/torque depending on ambient conditions. "

Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
378 Posts
Yes. "What you will see is that the ECU will vary the boost pressure to target the same load/torque depending on ambient conditions. "

Sent from my ONEPLUS A6013 using Tapatalk
Dope! Hope being BT is more satisfying than concluding this conversation btw, which snail ya go with??

Sent from my LG-H918 using Tapatalk
 

·
Registered
Joined
·
77 Posts
Discussion Starter #8
Dope! Hope being BT is more satisfying than concluding this conversation btw, which snail ya go with??

Sent from my LG-H918 using Tapatalk
Lol. GTX 2867R Gen2

Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
378 Posts
Right on! Have fun with that and be safe homie!

Sent from my LG-H918 using Tapatalk
 
1 - 10 of 10 Posts
Top