Ford Focus ST Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
338 Posts
Discussion Starter · #1 ·
Just wondering if anyone is running that exact setup. I recently purchased both and the downpipe went on without a hitch. After that, I attempted to install the cat-back for three (yes 3) days to no avail. It just seems like something is off. When the front section is bolted to the downpipe, and the middle ('s') section is slipped on and put into the exhaust hanger, it makes contact with the heat shield above the rear axle. And there is no way what so ever that the tailpipe portion is going on. I've tried twisting it every which way to get them to align, but nothing. Right now I'm waiting to see what Magnaflow says, but in the mean time I wanted to check and see if anyone had these two paired together. I'm almost 100% sure nothing is wrong with the downpipe because the remnants of the stock exhaust bolt up and align just fine.
 

·
Registered
Joined
·
483 Posts
I have Magnaflow cat back and I just received my Depo catted DP, not installed yet. I'll let you know if I have issues. I can tell you that I did have some fitment issues with the cat back with the factory DP. First was the cross member brace right behind the resonator. The brace hit the resonator no matter what I did and the exhaust hung low at that point where I had to push the exhaust up to tighten the brace. It was tight so nothing rattled but it wasn't right. Then there is a hanger on the Magnaflow tubing above the rear IRS cradle that the factory exhaust does not, but Ford did put a hanger on the chassis up there. Those hangers did not line up right and the one on the Magnaflow actually was contacting the chassis. I had a shop align the exhaust correctly, they had to cut and reweld the tubing close to the DP and they cut the rogue hanger off. They did this when they installed my jacking rails so price was cheap.
 
1 - 2 of 2 Posts
Top