Ford Focus ST Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
What's up everyone! Just picked up a 2013 ST2 last week and been having a blast driving it. I noticed something today I should of tried out when I test drove it but didn't. On the way home from work I tried to turn the cruise control on and couldn't get it to set a speed. I turn it on and it shows the little picture on the console, but when I press the set + button it won't set a speed. Just keeps saying set MPH. If I hold the set + button it will show the speed I am going with a line through it. I've tried different speeds and can't get it to set at all.

My buddy has a ST and I can set it fine on his. Anyone else have or hear about this problem before? Thank you!
 

·
Registered
Joined
·
210 Posts
Never heard of this, but if the line is through it that means its been canceled. Perhaps the cancel/resume button is stuck? Or the sensor for the brake or clutch is sending incorrect information?
 

·
Registered
Joined
·
354 Posts
FWIW, I had a regular 2012 Focus SE prior to my current ST and the cruise control gave me trouble. At the time I googled it and I could see a fair number of people having issues with Focus cruise. In my particular case it started working intermittently, then just stopped working completely for a period of about 6 months (would not turn on at all). Ironically, just a few weeks before I handed the car in at lease end, the cruise magically started working again as if nothing had happened......weird.


What's up everyone! Just picked up a 2013 ST2 last week and been having a blast driving it. I noticed something today I should of tried out when I test drove it but didn't. On the way home from work I tried to turn the cruise control on and couldn't get it to set a speed. I turn it on and it shows the little picture on the console, but when I press the set + button it won't set a speed. Just keeps saying set MPH. If I hold the set + button it will show the speed I am going with a line through it. I've tried different speeds and can't get it to set at all.

My buddy has a ST and I can set it fine on his. Anyone else have or hear about this problem before? Thank you!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Yeah I've tried both set buttons and get nothing with either. Even tried adjusting my steering wheel to different positions and trying to set it. No luck with that either. Everything else on the steering wheel works fine.

Have you tried using the set - option?
 

·
Registered
Joined
·
2,847 Posts
That's how it's supposed to operate...Mine will turn on but when you hit the + or -, it doesn't set.
Hey Screamin' Tangerine,

Welcome to the forum! Have you had a chance to speak with your Ford Dealer about this? I'm happy to to see how I can help. All I'll need is for you to shoot me a PM with your name, VIN, mileage, dealer, and best daytime phone number. :)

Nick
 

·
Registered
Joined
·
1 Posts
Hey Screamin' Tangerine,

Welcome to the forum! Have you had a chance to speak with your Ford Dealer about this? I'm happy to to see how I can help. All I'll need is for you to shoot me a PM with your name, VIN, mileage, dealer, and best daytime phone number. :)

Nick
Hello. I was looking for help on a 2014 ford focus manual trans with the dreaded cruise control will not set problem, line through the mileage displayed. I believe you helped someone else with this same problem. Was there a solution?
 

·
Registered
Joined
·
75 Posts
Had this happen to mine shortly after I got it. The speed sensor on the driver's front tire had come loose a bit and it wouldn't allow me to set a speed. It also threw a code (P1934). Hill start assist and cruise control didn't work until I got it plugged back in.

Hope it's an easy fix for you.
 

·
Registered
Joined
·
815 Posts
I never use cruise control, I've heard myths of people popping their motors while in cruise control.
 

·
Registered
Joined
·
395 Posts
I never use cruise control, I've heard myths of people popping their motors while in cruise control.
If you use it with a little common sense regarding LSPI, you should be able to prevent issues (I've been using cruise control on mine for the 55k miles that I have put on it and currently over 161k). If you have a hill coming up that is going to build boost in order to maintain speed, it is best to drop a gear (or two, depending on the hill and what gear you were in), which will also cancel cruise control.
 
1 - 16 of 16 Posts
Top