Ford Focus ST Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Tried to install my NRT catback this weekend but I am having nothing but fitment issues. The second resonator is laying against the heat shield. There is also a hanger above the rear suspension that seems to be in the way. Any tips would be greatly appreciated.
 

·
Registered
Joined
·
473 Posts
The guy that did mine had the same issue. It took 2 people to get it right, one to hold it where it needed to be and one to tighten it down. He said the clamps seemed so tight but the pipe was still lose. He had to add more elbow grease to get it actually tight. I also had him add a hanger to where there wasnt one on my 15. Looked like the rod wanted to touch the mount on the car but wasnt a hanger.
 

·
Registered
Joined
·
380 Posts
The best advice i can give is sometimes shields require some massaging, and the over the rear suspension part is just tight any way u go about it. If on jackatands the higher the back the easier it may be to get the pips into place.
Good lucky
 

·
Registered
Joined
·
660 Posts
The best advice i can give is sometimes shields require some massaging, and the over the rear suspension part is just tight any way u go about it. If on jackatands the higher the back the easier it may be to get the pips into place.
Good lucky
Somebody watched the CJPP MBRP cat back exhaust video a few too many times! :)

"Massaging the heat shield"
 

·
Registered
Joined
·
660 Posts
Should the kit includes a hanger for the rear?


Sent from my SM-N920T using Tapatalk
Yes. The Cobb kit comes with all 4 hangers. They are also much stiffer than the factory hangers.
 

·
Registered
Joined
·
570 Posts
It's probably like the Magnaflow exhaust. The resonator section even though it looks symmetrical, is not. It has a slight bend that keeps it from rubbing on that heat shield. Spin that section 180 degrees and try again.

I have no hands on experience with CNT, but it made a world of difference on my Magnaflow. At the very least it is worth a try.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #12 ·
Yeah. It took two of us but it's on. I get a little rattle up front when it's cold but it seems to go away.

Sent from my SM-N920T using Tapatalk
 

·
Registered
Joined
·
67 Posts
I had the exact same issues when installing mine. I was finally able to massage about 1/8" of space between the second res and the heat shield. Found out later that not near enough as there was vibrating when driving and banging when turning. I found the hanger welded to the over axle section was also about 2" off of where it needed to be and nearly lined up with the hanger point on the car.

Finally got tired of the buzzing and lifted the car in the drive. Pulled the whole system off, cut off the problem hanger (doesn't need supported there anyway) and reassembled ensuring everything was left way loose. Instead of tightening things down from front to rear or rear to front I started at the over axle section and worked out holding it right where it needed to be. Went together much better than it did the first time. Also found that flipping the rear passenger side hanger to the front side of the tab helped get the tits in the right location.

How are you guys feeling about the sound? I like the burbles on decel but it seems a little 'boomy'.
 
1 - 15 of 15 Posts
Top