Ford Focus ST Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Got some heavy rain the roads had decent amount of standing water. I was on the interstate going 55 mph hit some bumps and the rear of the car start to wander left to right I let out the gas and the traction light was flashing trying to gain control of the car which it did. Then a pickup truck passed and it caused the car to loose traction again briefly. Going 45 mph on a back road the car just doesn't feel planted it wants to wander and I don't feel in control or safe in rain. I have noticed it does it in dry weather just doesn't loose traction. Current tires are vercelli strada 2 stock size. The rear sway bar bushings are split I plan to replace those. The car was bagged when the previous owner had it. So stock suspension probably has 40k on it. Maybe something is loose or needs an alignment. Not sure if the dealership I bought the car from had a 4 wheel alignment done probably not. The steering wheel is straight though. Any thoughts ?
 

·
Premium Member
Joined
·
570 Posts
Might as well be the el cheapo-tires - and the busted sway bar bushings aren't great either.
You maybe should have a garage look at the suspension to make sure everything is tight and set up correctly.
 

·
Registered
Joined
·
448 Posts
Had this issue happen a while ago. And I use cheapo tires my self. Rear end was way out of alignment though.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
Had this issue happen a while ago. And I use cheapo tires my self. Rear end was way out of alignment though.
What's up buddy hope you been doing good. Yeah looking into a set of good new tires just not sure what I want to go with yet though lol. Gonna get some new rear endlinks as well. Cause that definitely made me wake up real quick lol. Also going to get an alignment
Might as well be the el cheapo-tires - and the busted sway bar bushings aren't great either.
You maybe should have a garage look at the suspension to make sure everything is tight and set up correctly.
Yeah gonna invest in new tires once I settle on what I want and get an alignment
 

·
Registered
Joined
·
448 Posts
@Bluest13 pretty good man finally getting to enjoy my car a little trying to work out a few issues here and there. Hope all
Is well for you, sorry you’re having these issues hopefully it’s nothing to crazy and it will get solved quickly.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #6
@Bluest13 pretty good man finally getting to enjoy my car a little trying to work out a few issues here and there. Hope all
Is well for you, sorry you’re having these issues hopefully it’s nothing to crazy and it will get solved quickly.
That's good to hear bro. I bet your happy to drive your ST again lol I'm sure you missed it. Me too this car and I have sure been through a lot since I got it lol. I think a new set of tires will help a lot + an 4 wheel alignment. The tires on it are cheapppp and I have read mixed reviews lol. The rear sway bar end links definitely need replaced cause whomever installed them tighten them way to much. They split the passenger side top bushing and mushroomed both sides bad.
 
1 - 6 of 6 Posts
Top