Ford Focus ST Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have a very unusual problem happening with my car. Every other day or so, near the end of my commute to work or home, the steering wheel will start to vibrate slightly and when I accelerate or brake, the car pulses, it is not a smooth acceleration or braking. Also the next time I stop, the brakes almost like stick a little and it makes a lurching noise when stopped even on the slightest of inclines. It smells like a combination of clutch, brake, and electrical burning when I finish my commute. No lights ever come up on the dash. This issue has been happening for about the last month. I replaced rotors and pads less than a year ago. Car is an early 2014. Brakes are Ferrodo DS2500 and Centric rotors with OEM fluid.

I plan to pull apart the brakes next week and clean them up and re grease them. Anything I should look for when I do this? Anybody else have the same issue or ideas what this could be?
 

·
Registered
Joined
·
1,250 Posts
Check easy things first. You can disable the hill assist and if the problem persists, you know its not that. Brake fluid level and color are easy. I would check the ABS connections at each wheel to make sure they are seated properly/clean. If those all look fine then i would move to taking apart the brakes.

After your drive, walk around your car and put your hand near the wheels/rotors, if you notice one feels hotter, that caliper could be sticking
 

·
Premium Member
Joined
·
3,424 Posts
ABS or sticking caliper.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
I should add that the smell and extra heat first started on the passenger side and moved to the drivers side in the past few weeks.

And the first thing I checked was hill assist as I hate that feature and it was still off.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
So here is what ended up happening. About a week ago the check engine light came on and it was a p1490 so I took it to the dealer since it would be covered under the recall. So that explained why the car was running a little weird. For the brakes, I checked the ABS connection and it was fine and clean. I cleaned the sliders and that did not fix the issue. So a new caliper fixed the issue.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
3 Participants
04deamon
Ford Focus ST Forum
We’re the premiere Ford Focus ST forum with discussions on the 2013+ Focus ST. Join the community and see the latest news, photos, videos, classifieds, reviews, events and more!
Full Forum Listing
Top