Ford Focus ST Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
This is my first post so please bare with me. I purchased a 2016 ST1, after about 5 months i decided to put a Turbosmart BOV on to replace my stock one. I had it on for about 2 weeks and decided to take it off because i got annoyed hearing the turbo spool through every gear, So put my stock BOV back on. As soon as i put the stock BOV back on ive noticed my turbo doesnt sound the same as it did before the turbosmart BOV. Im still holding boost pressure and can hear the whistle when the turbo builds, But i dont hear the quiet pssshhhh the factory BOV used to make. So my main question is, Is my turbo still releasing the excess pressure like it should?
Very worried!
Thanks in advance!
 

·
Registered
Joined
·
165 Posts
When you let off the throttle does your boost needle drop fast, like it normally would, or slower?

Not certain but that would be my guess of a symptom of pressure not venting.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
My boost needle behavior is exactly like it was before, normal. I think most of this is in my head, at least that's what my friends are telling me. But with my stock valve I could rev the engine and hear the turbo spool and go pssshhhh. Now when I rev it I can barely hear it spool and it doesn't go psssshhhh at all. Not even when I fully open it up.
 

·
Registered
Joined
·
2,754 Posts
My boost needle behavior is exactly like it was before, normal. I think most of this is in my head, at least that's what my friends are telling me. But with my stock valve I could rev the engine and hear the turbo spool and go pssshhhh. Now when I rev it I can barely hear it spool and it doesn't go psssshhhh at all. Not even when I fully open it up.
If you are reving it up fairly quickly, and jumping off the gas peddle, and you hear NOTHING from the BOV, then your BOV valve might be stuck closed, and is not a good thing at all. You should always be hearing the psssh.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
That is the conclusion I came to as well, how do I fix this? Do I need to take it off and examine it and reinstall? Or purchase a new one? Thank you for the help btw!
 

·
Super Moderator
2017 Ford Fusion Sport
Joined
·
8,200 Posts
There are some other guys on here who had issues like this. Taking it apart and lubing and cleaning it is a pretty easy process. If that doesn't work then contact them and they should be able to help you without having to spend more money.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
I also was recently corrected in another discussion that the car stock comes with a BPV, not a BOV. So technically I reinstalled the factory BPV to be clear. However, it could still be stuck closed, right?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Can I take my wheel off, rev the engine and physically see if the valve opens or closes to see if it being stuck closed is really the problem? Or is that not possible?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
My boost needle behavior is exactly like it was before, normal. I think most of this is in my head, at least that's what my friends are telling me. But with my stock valve I could rev the engine and hear the turbo spool and go pssshhhh. Now when I rev it I can barely hear it spool and it doesn't go psssshhhh at all. Not even when I fully open it up.
If you are reving it up fairly quickly, and jumping off the gas peddle, and you hear NOTHING from the BOV, then your BOV valve might be stuck closed, and is not a good thing at all. You should always be hearing the psssh.
I hearing the whistle when the turbo builds but when I let of the throttle there is no pssshh sound at all.
 

·
Registered
Joined
·
23 Posts
Can I take my wheel off, rev the engine and physically see if the valve opens or closes to see if it being stuck closed is really the problem? Or is that not possible?
you may be able to hear it but there is nothing visible from the outside of the valve that moves
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #11 ·
Thanks! Well yesterday I took my valve off, examined it and put it back and everything still the same. I guess most of this is in my head of it not sounding the same as it did before. And my car runs normal and I'm sure if there was something going on under the hood I would get some kind of code misfire sent to my computer. The car only has 4600 miles on it.
 

·
Registered
Joined
·
558 Posts
Thanks! Well yesterday I took my valve off, examined it and put it back and everything still the same. I guess most of this is in my head of it not sounding the same as it did before. And my car runs normal and I'm sure if there was something going on under the hood I would get some kind of code misfire sent to my computer. The car only has 4600 miles on it.
The stock BPV vents into the airbox so it does not pppssssshhhhh. It pops and that is muffled by the airbox. Now a BOV on the other hand does make noise. I only hear my turbo spool when I start the car. Hear the BPV barely and if I am paying attention to hear it. And it is almost silent.
 
  • Like
Reactions: fordboi415
1 - 12 of 12 Posts
Top