Ford Focus ST Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I've gotten everything in and been running stratified fash tune a couple weeks now. Everything seems to be working well, car definitely feels powerful and I'm extremely pleased. Im not getting the 21 to 23 psi though, most I've gotten is 19.26. Is this close enough or am losing it somewhere? Would it be worth going back over all the hose clamps and connections? I replaced the intercooler, piping, and blowoff valve all at the same time.
 

·
Registered
Joined
·
118 Posts
I've gotten everything in and been running stratified fash tune a couple weeks now. Everything seems to be working well, car definitely feels powerful and I'm extremely pleased. Im not getting the 21 to 23 psi though, most I've gotten is 19.26. Is this close enough or am losing it somewhere? Would it be worth going back over all the hose clamps and connections? I replaced the intercooler, piping, and blowoff valve all at the same time.
Wouldn't hurt to check, just for peace of mind. But sounds fairly normal, our ecu has a torque target so you wont always see the same psi for the same power. If its cooler weather were you are that can possibly be why too, cooler weather = more dense air = less psi for turbo to need to work!
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
Wouldn't hurt to check, just for peace of mind. But sounds fairly normal, our ecu has a torque target so you wont always see the same psi for the same power. If its cooler weather were you are that can possibly be why too, cooler weather = more dense air = less psi for turbo to need to work!
Beautiful pacific Northwest, cold,cloudy and rain until july
 
1 - 3 of 3 Posts
Top