Ford Focus ST Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 · (Edited)
Installed my 2867 even reinstalled it still having same issue. Car makes peak boost then tapers down and goes back up under WOT. Tuner told me not to mess with the wastegate that it wasn’t the problem. I used fuel lines for my boost controller after switching from the lines they sell for the turbo swap for our cars. Any ideas on what it could be? Gonna go over my charge pipes again this weekend the hot side is good 100% just checked it but I’ll check cold side when I change my oil. Included is a picture of my wastegate setting. Edit: my tuner is very reputable I trust him just trying to get an idea of what it could be.
 

Attachments

·
Registered
Joined
·
5,568 Posts
I would still check the wastegate. Only way to really check it is to put pressure to it and see where it starts to crack open. You want it between 14-17 psi depending on how much boost you want to run. Other than that check the solenoid routing and for boost leaks

017.jpg
 

·
Super Moderator
Joined
·
9,531 Posts
I would still check the wastegate. Only way to really check it is to put pressure to it and see where it starts to crack open. You want it between 14-17 psi depending on how much boost you want to run. Other than that check the solenoid routing and for boost leaks

View attachment 301354
That's a high tech diagram right there! Funny though, even I can understand it!
 
  • Like
Reactions: SIstomper
1 - 5 of 5 Posts
Top