Ford Focus ST Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter · #1 ·
Replaced my Turbosmart with a Boomba BOV today and had a quick question to those who have installed one.

On the 2 longer bolts, the spacers between the valve & bracket had some slop still after I snugged up all 3 fasteners. Car runs fine & holds boost but it was bugging me a little. Anyone else notice this?
 

·
Registered
Joined
·
408 Posts
They should have no slop at all. Maybe @boomba can chime in. Double check as well just incase

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Yeah, pretty sure they should be snugged up pretty tightly. Swapping wheels in the morning, so I'll try to remember to reach in and double-check for ya.
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #4 ·
Thanks. I’m gonna have to tear into it again and see what I could have done wrong. I do know for sure it’s seated flush and that I didn’t dare go any tighter on those nuts
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #6 ·
Everything should be totally snug once you are done tightening the screws. Make sure the threads on your vehicle are clean and not crossthreaded. Also make sure that spacers are in the right locations.
I’m defiantly gonna have to get back out there and check it out. Unfortunately all hells breaking loose with an ice storm today.

The spacers are in the right locations (top hole & bottom left) and the bolts went in easy enough that I don’t think they are cross threaded.
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #8 ·
I haven’t had a chance to get back out there and tear into it again yet. It’s been like 15 degrees lol


Sent from my iPhone using Tapatalk Pro
 
1 - 10 of 10 Posts
Top