Ford Focus ST Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hi looking for a quick reply.

I disconnected my AIC the other day and now I need to reconnect it.

Can someone please verify for me what position it's supposed to go back into?
Circuit component Office equipment Electronic component Electronic engineering Electrical wiring
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
Direction of the tap is very important. Also when tapping a fuse in the BJB (battery junction box). Another point to note is the original fuse size (amps) that your trying to use.

If you're attempting to pull 15 amps from a 5 or 10 amp supply bad things will occur. Tell me what you need. Constantly Hot, Ignition Hot? If you're really in need of higher thought put be need it switched Ignition Hot then you can always add a fuse to the HVJB (high voltage junction box) and put a relay that can be triggered by the Ignition relay output.

Just let me know.
Electrical wiring Audio equipment Cable Gas Electronic component

Hood Motor vehicle Automotive tire Automotive lighting Trunk


Tha
Automotive tire Hood Coil Motor vehicle Electrical wiring



Thanks I think I may have found a a bad ground. Screw was definitely loose...not sure if I or Ford did that...either way no bueno.

Going to get a bonding brush and hopefully fix that. I don't know if it will solve my problem, keeping my fingers crossed. I am hoping that arching didn't make everything worse. 🥴

Plan on replacing all of the fuses on the HVLB, already ordered from Tasca.

Can anyone confirm are there a few more grounds underneath the battery box? Seems like a project for tomorrow.
 
1 - 3 of 3 Posts
Top