Ford Focus ST Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, I have a bit of a project on the go a 7 based kit with focus ST engine and electronics.

What I have is more of a test bed than a car, I'm currently working on building the car with 2.0L ecoboost from a face lift mk3.5 Focus ST. As an experiment in saving some cash over the cost of full on racing ECU and giving me the option to use many of the tuning products available for the ST, I'm attempting to use most of the looms, electronics and fuse boxes from the ST.

I've checked the high and medium speed CAN bus and they are correctly terminated. I'm able to see and configure modules using Focccus or FORScan.

Currently I have the PCM, BCM and a keyless fob from the same car and a full set of keyless antenna and an rfa module from another source along with all the required looms. I can communicate with all the modules, see DTC's and read and write to the central config just fine. There is nothing in the DTC's I wouldn't expect but the PCM does show a P160A that doesn't clear. Currently in FORScan I don't see a PATS option under service procedures and I guess I'll need to get the rfa recognized by the PCM.

Running PCM Module Initialization/relearn gives a "Service procedure has been interrupted" but maybe this is because I cant get an 'ignition on' status. Do I need the ignition on for the relearn procedure to work and should I be seeing the PATS option for a mk3.5 2015 focus?

Would I be better using an earlier version of FORScan rather than 2.3.11 beta?

Has anyone else been able to use the pats config on a MK3.5?


Regards
Ec0beast7


Posts: 1
Joined: Sun Oct 22, 2017 9:02 pm
Vehicle: Focus ST 250 2.0 Ecoboost
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Well I got a little bit further with the FORScan config today. I was seeing config DTC's from the PCM and BCM. I previously tried an initialisation and relearn on the PCM which failed. I figured this was because as yet I haven't got the PATS to work so I wasn't able to get an ignition on state. To get around this I wired a switch across the ignition relay and this did the trick all configuration DTC's are cleared.

However I still don't see a PATS programming option in FORScan ?

Has anyone seen PATS programming available for a MK3.5?

Cheers
Rich
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Also does anyone know where this connector goes? There are two of these on the dash harness. I know one goes to the roof harness but this one placed near the steering column connectors on the harness. I have a hard copy of the 2014 focus wiring manual which mostly matches up with the 2015 harnesses I have but this little blighter is nowhere to be seen. It looks fairly important as center spades look like they need to carry some juice. It also has the high-speed canbus looping through it. Unconnected it brakes the canbus so I've had to bridge the canbus wires to talk to the pcm.

Answers on a postcard ?

Cheers
Rich
 

Attachments

1 - 4 of 4 Posts
Top