Ford Focus ST Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I heard the 2016 RMM was replaced and no longer needs an aftermarket replacement. Can any shed light on that?

Sent from my SM-G935T using Tapatalk
 

·
Registered
Joined
·
74 Posts
I heard the same thing about the 2015's that they upgraded to the efocus mount. However I still changed mine out with a Cobb RMM. I did get a little more vibration at idle. But It definitely helped smooth out the shift between 1st and 2nd a LOT. So while the 2015/16 mount is stiffer, it is still not as stiff as the Cobb/CPE/etc.
 
  • Like
Reactions: ferris

·
Registered
Joined
·
2,063 Posts
I had the early mounts and when I changed to the current ones (they change all three) it was a vast improvement. At this point it's a trade off between how much vibration vs. smoothness you want if you go stiffer. The originals were simply horrid.
 

·
Registered
Joined
·
96 Posts
I had the e-focus mount on my '15 but still bought the COBB RMM. I'd still get the 1-2 bang. Even my Dad who's a seasoned MT driver (50 years) thought he was doing something wrong when he first drove my car when I had the old mount.
 

·
Registered
Joined
·
1,480 Posts
Exactly what @lug said. Stock 2013 mounts were horrible. Upgraded OEM mounts (14 + ST gets them and 2013 could have them done as TSB) are an improvement, but you still not stiff enough for some. I added a Mountune RMM to my upgraded OEM mounts and the setup is perfect to me. Upgraded mounts plus one of the less aggressive aftermarket RMMs is a popular option around here for daily drivers. I only get a little vibration if the AC is on, but when driving hard the car feels more stable (instead of like the engine is throwing itself around).
 

·
Registered
Joined
·
30 Posts
I have a 2016 st. Its a week and a half old. I have not driven an older ST. I do want to say that shifting hard into second you can still get that awful CLUNK sound from the RMM. I do have to say I have never experienced wheel hop once at all in this car. I installed the green filter and reset the KAM last night so i needed to blast through the gears for an hour. I only get chirps and a tiny spin sometimes.
 

·
Registered
Joined
·
34 Posts
I have a 2016 st, Installed my Cobb RMM at around 2125 miles. Major difference. No wheel hop at all. I would suggest doing it.
 

·
Registered
Joined
·
1,525 Posts
You guys must really be hammering those gears.. I replaced my 2013 with the e-focus mount and have no complaints.
 

·
Registered
Joined
·
439 Posts
or you just drive like a total granny...
Or you really hammer your car - I don't mean just you, but the guys that still have issues after the mounts have been rectified by the TSB.

No issue at all with my '13 after getting the RMM replaced with the e-focus either. No bangs with launch control in first and none in second either and my car has been tuned.
 

·
Registered
Joined
·
59 Posts
I have a 2016, the stock mounts would still give you wheel hop on hard launches, nothing too bad light before. Upgraded to the CPE stage 2, no hp just spin and hook. Decent vibes at ignition or going into first but almost nothing after that. If you give it a little more gas and clutch and 1St is close to smooth.
 

·
Registered
Joined
·
326 Posts
Might as well ask in here...

Best RMM? I don't mind vibration (I'm used to Mustangs), just want to get rid of the hop and clunk.
Probably cpe stage 2


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
59 Posts

·
Registered
Joined
·
326 Posts
I have a 2016, the stock mounts would still give you wheel hop on hard launches, nothing too bad light before. Upgraded to the CPE stage 2, no hp just spin and hook. Decent vibes at ignition or going into first but almost nothing after that. If you give it a little more gas and clutch and 1St is close to smooth.
Granted i didn't go with cpe stage 2 because I don't like vibration. I got a mountune

Sent from my SM-N910V using Tapatalk
 

·
Registered
Joined
·
59 Posts
I should have prefaced my earlier statement by saying the ST is not my DD so the vibrations don't bother me too much. First long trip since installing it will be this weekend so we will see...I have a feeling the wife will not be happy :smile:
 

·
Registered
Joined
·
59 Posts
Not trying to thread jack but Saybo how do you like the Depo DP? I am looking at this for my next mod but I am on the fence due some install issues I keep hearing about. The price is almost too good to pass up though.
 

·
Registered
Joined
·
610 Posts
Not trying to thread jack but Saybo how do you like the Depo DP? I am looking at this for my next mod but I am on the fence due some install issues I keep hearing about. The price is almost too good to pass up though.
So you post this in a rear motor mount thread...


Sent from my iPhone using Tapatalk
 
1 - 20 of 23 Posts
Top