Ford Focus ST Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all. I am stumped on this one. I had a pothole strike a couple months ago hard enough to blow out my passenger front tire and damage the rim. Immediately after, I put on the factory full-size spare and it drove great, just like new. Once I got the new tire and rim, I took it into the shop and had them mount and do a full alignment. After that, the car is pulling harder to the right under power than it ever has. It's always had some torque steer, but it just seems exaggerated now. What baffles me is why it wasn't there with the spare mounted. The guy at the tire shop says the motor mount may have been damaged, which could make sense, but again, why would it be ok with the spare mounted. Any thoughts?
Thanks.
 

·
Super Moderator
Joined
·
9,548 Posts
Hi all. I am stumped on this one. I had a pothole strike a couple months ago hard enough to blow out my passenger front tire and damage the rim. Immediately after, I put on the factory full-size spare and it drove great, just like new. Once I got the new tire and rim, I took it into the shop and had them mount and do a full alignment. After that, the car is pulling harder to the right under power than it ever has. It's always had some torque steer, but it just seems exaggerated now. What baffles me is why it wasn't there with the spare mounted. The guy at the tire shop says the motor mount may have been damaged, which could make sense, but again, why would it be ok with the spare mounted. Any thoughts?
Thanks.
The new tire gets better traction than the old tire or the spare?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I don't think that would be it, it's not like I was trying to break the spare loose, if anything, I was driving it easier because I was running on a spare.
 

·
Registered
Joined
·
530 Posts
Did you get a print out of the alignment results? Maybe they screwed up the alignment? Or just that the alignment is possibly different than before and just feels new? You're right, that is strange
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I did get a print out, I just wouldn't know how to tell from that if they did anything wrong or not. that's a good point though.
 

·
Registered
Joined
·
530 Posts
I did get a print out, I just wouldn't know how to tell from that if they did anything wrong or not. that's a good point though.
Well all the numbers should be as close to 0 as possible for toe, camber, and caster. Anything over like half a degree and they could have done better


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top